Bug 63578 - Runing on Platform (not IDE) does not respect splash settings, fonts...
Runing on Platform (not IDE) does not respect splash settings, fonts...
Status: VERIFIED DUPLICATE of bug 61551
Product: apisupport
Classification: Unclassified
Component: Harness
5.x
Sun Solaris
: P3 (vote)
: 5.x
Assigned To: Jaroslav Tulach
issues@apisupport
: SIMPLEFIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-02 14:05 UTC by Tomas Danek
Modified: 2006-02-14 17:57 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2005-09-02 14:05:52 UTC
when building suite on NB Platform (not whole IDE) as recommanded in tutorial,
branding setting don't take efect, platform is lauched with default splash and
font settings,etc. And what is even worse, created window components are not
present on lauched platform. Seems like something is wrong during building?! 
Launching on default platform (IDE) with only platform6 modules enabled works.
Comment 1 Jesse Glick 2005-09-02 19:23:06 UTC
This is news to me. Could you please

1. Provide some kind of steps to reproduce so we can be sure we are talking
about the same thing.

2. Do a build both from Platform and from IDE with platform6 cluster only, and
compare the resulting builds to see where they differ.
Comment 2 Tomas Danek 2005-09-06 11:00:48 UTC
Ad 1 - Yes, quite easy:
1) IDE 20050905, add a new platform in NBPM  (downloaded Platform 20050905)
2) Create module suite aaa, with defualt options, on Platform (not default IDE)
3) Create module bbb, in suite aaa
4) Create window component in bbb using wizard, check Open at app start,choose
position e.g. explorer
4) Change some branding properties in aaa, e.g. splash, fonts,...
5) Run aaa - changes didn't take effect (default splash + fonts can be seen)
window is not displayed!!
6) If you now change platform of aaa to default IDE and RUN, everything seems to
be ok.
(except CNFE, already filed as 63575)

Add 2 - I'll attach soon
Comment 3 Tomas Danek 2005-09-06 11:16:46 UTC
Got it! I did not notice 

"Ignored unknown option: api
Post-initialization command-line options could not be run."

small statment in output window.
 
Now the problem is clear: 
There's a problem with path. I used platform placed in 
/space/platform api testing/netbeans
but it did not correctly handled folder name with white spaces.

If I placed the same platform in 
/home/tm159668/Platform/netbeans
problem disappeared.

Seem to me like a simplefix now, changing kw.
Comment 4 Jesse Glick 2005-09-06 19:10:01 UTC

*** This issue has been marked as a duplicate of 61551 ***
Comment 5 Tomas Danek 2005-09-07 13:00:32 UTC
verified as dupl.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo