Bug 63401 - Using relative paths in projects
Using relative paths in projects
Status: RESOLVED WORKSFORME
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
5.x
All All
: P3 (vote)
: 5.x
Assigned To: Tomas Zezula
issues@projects
:
: 63400 (view as bug list)
Depends on:
Blocks: 63267
  Show dependency treegraph
 
Reported: 2005-08-31 10:37 UTC by Tomas Zezula
Modified: 2005-09-08 16:52 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Zezula 2005-08-31 10:37:03 UTC
Currently the Ant based project uses relative paths only when the referenced
resource is under the project itself or under the same CVS root. This should be
changed to prefer the relative paths if possible.
Comment 1 Tomas Zezula 2005-08-31 11:02:20 UTC
*** Issue 63400 has been marked as a duplicate of this issue. ***
Comment 2 Tomas Zezula 2005-08-31 12:33:48 UTC
Checking in ant/project/apichanges.xml;
/cvs/ant/project/apichanges.xml,v  <--  apichanges.xml
new revision: 1.9; previous revision: 1.8
done
Checking in ant/project/manifest.mf;
/cvs/ant/project/manifest.mf,v  <--  manifest.mf
new revision: 1.13; previous revision: 1.12
done
Checking in
ant/project/src/org/netbeans/spi/project/support/ant/ReferenceHelper.java;
/cvs/ant/project/src/org/netbeans/spi/project/support/ant/ReferenceHelper.java,v
 <--  ReferenceHelper.java
new revision: 1.28; previous revision: 1.27
done
Checking in
ant/project/test/unit/src/org/netbeans/spi/project/support/ant/ReferenceHelperTest.java;
/cvs/ant/project/test/unit/src/org/netbeans/spi/project/support/ant/ReferenceHelperTest.java,v
 <--  ReferenceHelperTest.java
new revision: 1.20; previous revision: 1.19
done
Checking in
projects/queries/src/META-INF/services/org.netbeans.spi.queries.CollocationQueryImplementation;
/cvs/projects/queries/src/META-INF/services/org.netbeans.spi.queries.CollocationQueryImplementation,v
 <--  org.netbeans.spi.queries.CollocationQueryImplementation
new revision: 1.5; previous revision: 1.4
done
RCS file:
/cvs/projects/queries/src/org/netbeans/modules/queries/AlwaysRelativeCollocationQuery.java,v
done
Checking in
projects/queries/src/org/netbeans/modules/queries/AlwaysRelativeCollocationQuery.java;
/cvs/projects/queries/src/org/netbeans/modules/queries/AlwaysRelativeCollocationQuery.java,v
 <--  AlwaysRelativeCollocationQuery.java
initial revision: 1.1
done
RCS file:
/cvs/projects/queries/test/unit/src/org/netbeans/modules/queries/AlwaysRelativeCollocationQueryTest.java,v
done
Checking in
projects/queries/test/unit/src/org/netbeans/modules/queries/AlwaysRelativeCollocationQueryTest.java;
/cvs/projects/queries/test/unit/src/org/netbeans/modules/queries/AlwaysRelativeCollocationQueryTest.java,v
 <--  AlwaysRelativeCollocationQueryTest.java
initial revision: 1.1
done
Checking in java/project/apichanges.xml;
/cvs/java/project/apichanges.xml,v  <--  apichanges.xml
new revision: 1.12; previous revision: 1.11
done
Checking in java/project/manifest.mf;
/cvs/java/project/manifest.mf,v  <--  manifest.mf
new revision: 1.15; previous revision: 1.14
done
Checking in
java/project/src/org/netbeans/modules/java/project/BrokenReferencesModel.java;
/cvs/java/project/src/org/netbeans/modules/java/project/BrokenReferencesModel.java,v
 <--  BrokenReferencesModel.java
new revision: 1.19; previous revision: 1.18
done
Comment 3 ametzger 2005-09-07 21:48:53 UTC
Using the 5-Sep-2005 daily build of NetBeans 5.0 and adding library files to a
Web application, relative paths are still only used for individual FILES under
the same CVS or project but absolute paths are used for FOLDERS under the same
CVS or project.  For a project which depends on many other open source
components, it is painful to achieve sharability because each individual jar
file has to be added to a web project library instead of being able to point at
a directory containing jar files.  IMHO this should be addressed for the 5.0
release.  Easy team development is a must.

I understand from the FAQ, other issues, and the mailing lists that the team
intends to eventually solve this problem in a big way by allowing relative
libraries to be defined etc.  If that can't be achieved for 5.0, then at least
the ability to have relative paths for Folders should be put in.  IMHO.

Comment 4 Tomas Zezula 2005-09-08 07:26:19 UTC
This issue does not affect the global Libraries which are added always in
absolute way (the per project libraries which used relative paths were dropped),
it only affects the jar/folders and path to dependent projects.
It works fine for me in j2seproject.
If you add an Jar file in the customizer the property file.reference.xxx is
defined in the project.properties in the relative way and the same property is
defined in the private.properties in the absolute way (the private folder should
not be shared)
If it does not work for you in the web project it means that the some parts of
the web project does not use a standard API for creating the references, you
have to fill a DEFECT to web project and attach the project.properties and
private.properties files to the issue.
Comment 5 zikmund 2005-09-08 16:52:58 UTC
To ametzger: you are talking about directories containing JAR files. How do you
add them to the classpath? Could you please put here simple scenario how to
create such reference in WebApp from scratch? It would help us understand your
needs. Thanks!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo