Bug 63285 - AIOOBE from DocumentContent.copySpanChars in JavaI18nSupport$JavaI18nFinder.findNextString
AIOOBE from DocumentContent.copySpanChars in JavaI18nSupport$JavaI18nFinder.f...
Status: RESOLVED WORKSFORME
Product: java
Classification: Unclassified
Component: I18N
5.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@java
issues@java
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-30 00:39 UTC by Jesse Glick
Modified: 2007-09-10 18:28 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Stack trace (1.22 KB, text/plain)
2005-08-30 00:39 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2005-08-30 00:39:05 UTC
050828, while trying to run I18N Wiz on apisupport/{project,refactoring}/src (it
does not work, wizard breaks halfway).
Comment 1 Jesse Glick 2005-08-30 00:39:37 UTC
Created attachment 24330 [details]
Stack trace
Comment 2 Marian Petras 2005-10-20 14:55:20 UTC
Probably caused by a threading issue:

The topmost I18n-module-related callstack frame in the stacktrace is:

    buffer = document.getText(0, document.getLength()).toCharArray();

which seems totally ok. But it is called from non-AWT thread which is the
probable cause of this bug.

Accepted.
Comment 3 Tomas Stupka 2007-09-10 18:28:46 UTC
tried several times on the reported scope and also on some another projects but could not reproduced. Seems to be fixed
(the bug is quite old).

feel free to reopen if it should still appear.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo