Bug 63149 - [50cat] NBM and suite projects should support delete
[50cat] NBM and suite projects should support delete
Status: VERIFIED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
5.x
All All
: P1 (vote)
: 5.x
Assigned To: Martin Krauskopf
issues@apisupport
:
: 65514 67021 67343 67921 71906 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 11:15 UTC by Jesse Glick
Modified: 2006-01-27 12:08 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
messages.log (37.53 KB, text/plain)
2005-10-06 05:38 UTC, ogaki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2005-08-26 11:15:18 UTC
For suite component module projects, of course it should be removed from the
suite's module list too.
Comment 1 Martin Krauskopf 2005-09-15 05:00:25 UTC
High priority feature for the next release.
Comment 2 Jesse Glick 2005-10-03 21:56:33 UTC
*** Issue 65514 has been marked as a duplicate of this issue. ***
Comment 3 ogaki 2005-10-06 05:38:45 UTC
Created attachment 25582 [details]
messages.log
Comment 4 ogaki 2005-10-06 05:39:19 UTC
When the project of the same name was created immediately
after closing the project
and deleting the folder of the project outside IDE,
the error had occurred inside. messages.log is attached.

[ step ]

1. File > New Project >
     Categories:NetBeans Plug-in Modules, Projects:Module Project
2. Next >
     Project Name:MyFirstModule
3. Next >
     Code Name Base: org.myorg.myfirstmodule
4. Finish >
5. File > Close "MyFirstModule"

* The project folder "MyFirstModule" is deleted outside IDE. 
* 1 to 4 is repeated. 
* Here, the error was outputted to messages.log. 

6. File > New File
    Categories: NetBeans Module Development, File Types: Action
* Here, the Null Pointer exception has happened.

7. Next > Next > Next >
8. Class Name: MyFirstAction, Display Name: My First Action
* Even if it can do well, the error may be outputted.
Comment 5 Tomas Danek 2005-10-17 15:36:29 UTC
copy/paste/rename/delete on module/suite as described in dupes.
Comment 6 Tomas Danek 2005-10-17 15:39:03 UTC
*** Issue 66081 has been marked as a duplicate of this issue. ***
Comment 7 Martin Krauskopf 2005-10-18 10:32:37 UTC
*** Issue 67021 has been marked as a duplicate of this issue. ***
Comment 8 Jan Lahoda 2005-10-22 15:59:37 UTC
*** Issue 67343 has been marked as a duplicate of this issue. ***
Comment 9 vbrabant 2005-10-23 22:24:53 UTC
Just added [50cat] prefix because my issue is marked as duplicate of this one
Comment 10 pzajac 2005-11-01 15:20:05 UTC
*** Issue 67921 has been marked as a duplicate of this issue. ***
Comment 11 Martin Krauskopf 2005-12-19 17:00:19 UTC
I would like to integrate for 5.1 M1. Presuambly also other similar tasks
(move/rename/copy). But could be worked on separately, I believe from the first
look at the Project API. Do not know that too much yet :)
Comment 12 Martin Krauskopf 2006-01-02 17:06:17 UTC
NBM module done. Suite not yet.
Not sure if modules in NB cvs tree should be handle in some special way.

NbModuleProject.java; 1.134 -> 1.135;
Util.java; 1.25 -> 1.26;
ui/ModuleActions.java; 1.16 -> 1.17;
ui/ModuleOperations.java; 1.1
test/unit/ui/ModuleOperationsTest.java; 1.1
ui/SuiteLogicalView.java; 1.20 -> 1.21;
Comment 13 Martin Krauskopf 2006-01-04 12:04:08 UTC
Continuing....

1. do the clean to allow a clean deletion
2. do not hardcode build.xml
3. deleting also .cvsignore which is generated under certain conditions
(question? - is this a good idea?)

test/unit/ui/ModuleOperationsTest.java; 1.2 -> 1.3;
ui/ModuleOperations.java; 1.1 -> 1.2;
Comment 14 Martin Krauskopf 2006-01-04 13:30:22 UTC
Probably finished. Let's reopen and/or file a new bug. Tomasi or Zajo could you
test/comment this? Thanks.

- when module is deleted and is a suite component it is also removed
  from it's suite and vice versa.
- when suite is deleted all of its suite component become standalone modules
- otherwise hopefully expected behaviour

test/unit/ui/SuiteOperationsTest.java; 1.1
ui/SuiteOperations.java; 1.1
ui/SuiteActions.java; 1.11 -> 1.12;
suite/SuiteProject.java; 1.26 -> 1.27;
ui/ModuleOperations.java; 1.2 -> 1.3;
Comment 15 Tomas Danek 2006-01-04 13:39:23 UTC
minor comment - I'm not an UI expert, but delete module dialog  seems too large
for me on Win XP (vertically - there's too much blank space under "also delete
.... sources").
Comment 16 Martin Krauskopf 2006-01-04 13:52:52 UTC
> but delete module dialog seems too large

Yes, I agree. Please file a bug against projects module. This dialog is provided
by them.
Comment 17 Tomas Danek 2006-01-04 14:14:08 UTC
> Yes, I agree. Please file a bug against projects module. This dialog is provided
> by them.

filed issue 70993.
Comment 18 Tomas Danek 2006-01-06 15:00:07 UTC
great! thanks. Verified as feature. (bugs - if any - will be filed in separate
issues)
Comment 19 Martin Krauskopf 2006-01-27 12:08:43 UTC
*** Issue 71906 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo