Bug 63132 - Exception throws some times
Exception throws some times
Status: RESOLVED DUPLICATE of bug 46813
Product: platform
Classification: Unclassified
Component: Filesystems
5.x
PC Windows XP
: P3 (vote)
: 5.x
Assigned To: rmatous
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 09:15 UTC by waynezhang
Modified: 2008-12-22 21:37 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description waynezhang 2005-08-26 09:15:13 UTC
Exception throws some times. May be when a background thread check/save project
information. Exception stack trace:

java.lang.IllegalArgumentException: URI has an authority component
[file://PERSVR02/homedrive/micsbwz/]
	at
org.netbeans.modules.masterfs.MasterURLMapper.getFileObjects(MasterURLMapper.java:48)
	at org.openide.filesystems.URLMapper.findFileObject(URLMapper.java:218)
	at org.openide.loaders.DataShadow.deserialize(DataShadow.java:398)
	at
org.openide.loaders.DataLoaderPool$ShadowLoader.createMultiObject(DataLoaderPool.java:884)
	at
org.openide.loaders.MultiFileLoader.handleFindDataObject(MultiFileLoader.java:73)
	at org.openide.loaders.DataObjectPool.handleFindDataObject(DataObjectPool.java:111)
	at org.openide.loaders.DataLoader.findDataObject(DataLoader.java:358)
	at org.openide.loaders.DataLoaderPool.findDataObject(DataLoaderPool.java:386)
	at org.openide.loaders.FolderList.createBoth(FolderList.java:701)
	at org.openide.loaders.FolderList.getObjects(FolderList.java:512)
	at org.openide.loaders.FolderList.access$200(FolderList.java:50)
	at org.openide.loaders.FolderList$ListTask.run(FolderList.java:880)
	at org.openide.util.Task.run(Task.java:207)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:469)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:870)


NOTE:
my ${USER_HOME} is clocated in a network drive: //PERSVR02/homedrive/micsbwz/
Comment 1 Pavel Rehak 2005-08-30 09:39:45 UTC
Would you be so kind and provide us with some additional informations (or reproducible scenarios) how 
did you get this exception?
We can hardly track down core of your problem just from attached exception.
Thank you.
Comment 2 Milan Kubec 2005-09-27 15:00:30 UTC
Reassigning for evaluation, you might get some info from the exception.
Comment 3 waynezhang 2005-09-29 10:16:12 UTC
It OK in beta version. 
This exception throws regularly when I use the DEV build. No specific
operertions to trigger that exception.(I guess there is a background thread
checking something).

Thanks.

Wayne
Comment 4 waynezhang 2005-10-03 02:55:54 UTC
I meet the same Exception in 5.0 beta today, just when I open the IDE whith
my project opened. Please check the source code reported in the Exception.

Thanks!


****************
java.lang.IllegalArgumentException: URI has an authority component
[file://PERSVR02/homedrive/micsbwz/]
	at
org.netbeans.modules.masterfs.MasterURLMapper.getFileObjects(MasterURLMapper.java:48)
	at org.openide.filesystems.URLMapper.findFileObject(URLMapper.java:218)
	at org.openide.loaders.DataShadow.deserialize(DataShadow.java:440)
	at
org.openide.loaders.DataLoaderPool$ShadowLoader.createMultiObject(DataLoaderPool.java:900)
	at
org.openide.loaders.MultiFileLoader.handleFindDataObject(MultiFileLoader.java:73)
	at org.openide.loaders.DataObjectPool.handleFindDataObject(DataObjectPool.java:111)
	at org.openide.loaders.DataLoader.findDataObject(DataLoader.java:358)
	at org.openide.loaders.DataLoaderPool.findDataObject(DataLoaderPool.java:402)
	at org.openide.loaders.FolderList.createBoth(FolderList.java:701)
	at org.openide.loaders.FolderList.getObjects(FolderList.java:512)
	at org.openide.loaders.FolderList.access$200(FolderList.java:50)
	at org.openide.loaders.FolderList$ListTask.run(FolderList.java:880)
	at org.openide.util.Task.run(Task.java:207)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:469)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:870)
Comment 5 waynezhang 2005-10-03 04:05:43 UTC
Hi,
I have got the reason that cause the exception: my defautl "user.home" or Netbeans
home dir is a network drive - [//PERSVR02/homedrive/micsbwz/].
When I set the user.home to local dir, no exception report. How error, we should
explore why Netbeans throw this exception when useing a network drive, it should be
OK.

Thanks!
Comment 6 rmatous 2005-10-11 11:46:16 UTC

*** This issue has been marked as a duplicate of 46813 ***
Comment 7 waynezhang 2005-11-25 03:45:15 UTC
It appears in 5.0 Beta2 again, although I have set the userdir to my local file
system. On hint is, it only accured when I use jdk 1.5.0 (update 5), it will be
ok if I use jdk 1.6.0 (mustang build 56).
Comment 8 waynezhang 2005-11-25 03:46:36 UTC

*** This issue has been marked as a duplicate of 46813 ***
Comment 9 waynezhang 2005-11-25 04:34:38 UTC
The problem is, I have defined "-userdir" to local file system in command line,
why   
netbeans still check the default home dir? 
It seems work in 5.0 beta, but don't work in 5.0 beta 2 by this way.
Comment 10 waynezhang 2005-11-25 06:46:16 UTC
I have found why it works in 5.0 beta. I have changed the netbeans.conf in 5.0 beta 
as following:
   add 
      -J-Duser.home=c:\temp 
   to netbeans_default_options

It's ok now in beta2. 

But I still think we should use -userdir to override the JDK's user.home.    
Comment 11 Marian Mirilovic 2006-01-03 10:51:31 UTC
Too late for NB5.0, please reevaluate.
Comment 12 Marian Mirilovic 2006-01-20 10:27:18 UTC
NB doesn't support UNC paths. 

So, the first stack-trace shows that you are trying to access files
[file://PERSVR02/homedrive/micsbwz/]
that's the reason it doesn't work.

Your second attempt to specify NB userdir to 
C:/temp
works well.

*** This issue has been marked as a duplicate of 46813 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo