Bug 63084 - NetBeans freeze in debug mode
NetBeans freeze in debug mode
Status: RESOLVED WONTFIX
Product: serverplugins
Classification: Unclassified
Component: WebLogic
5.x
All Linux
: P2 (vote)
: 5.x
Assigned To: Libor Kotouc
issues@serverplugins
: RELNOTE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-25 17:27 UTC by Michal Mocnak
Modified: 2005-10-14 13:01 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (59.76 KB, text/plain)
2005-08-25 17:28 UTC, Michal Mocnak
Details
screenshot (104.72 KB, image/png)
2005-08-25 18:25 UTC, Michal Mocnak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Mocnak 2005-08-25 17:27:41 UTC
Found in the nb42dev build 200508241800

1. start weblogic9 server in debug mode
2. create simple j2ee application
3. debug it -> put a break somewhere into the code and then try to continue step
by step with step into the method feature
=> NetBeans totally freezes and you are not able to do anything...after a couple
of time it already refreshes itself and then freezes again
Comment 1 Michal Mocnak 2005-08-25 17:28:38 UTC
Created attachment 24235 [details]
thread dump
Comment 2 Pavel Buzek 2005-08-25 17:55:18 UTC
I am looking at this. Looks like it is "just" slow, not really frozen.
Comment 3 Michal Mocnak 2005-08-25 18:25:39 UTC
Created attachment 24237 [details]
screenshot
Comment 4 Michal Mocnak 2005-09-08 13:59:05 UTC
Priority increase to P1. It's a beta stopper because due to this issue it's
impossible to work with weblogic9 app server in debug mode.
Comment 5 Pavel Buzek 2005-09-10 01:48:00 UTC
I am testing on win xp, 1.5.4_04-ea and debugging a simple EAR works ok for me
(if I start debugging then that server is stopped so that I do not encounter
63179). I've seen another problem - the server is started in debug mode but the
IDE does not recognize it - probably timeout. But after I refresh the server and
start debugging the application again it works.

Interestingly, I do not see any weblogic plugin code in the stacktrace other
then the log trailer, the log trailer is definitely not causing deadlock or
bottleneck.
Comment 6 Pavel Buzek 2005-09-12 15:01:31 UTC
Cannot reproduce, downgrading to P2.
Can somebody test on winxp to check if this is a linux specific problem?
Comment 7 Michal Mocnak 2005-09-13 17:58:31 UTC
Ok. I have tested it inb win xp and it's how you said. It seems that it's the
problem reproducable only on linux.
Comment 8 Pavel Buzek 2005-10-12 18:45:05 UTC
Libore, can you please take this issue too. Let me know if you need my help (but
I do not have *nix and could not reproduce on win*p). Thanks.
Comment 9 Michal Mocnak 2005-10-14 13:01:02 UTC
Mark as WONTFIX. This problem is actual only for weblogic which is started with
Bea JDK (JRockKit). If you start wl with Sun JDK which is bundled with WebLogic
then everything is OK. And how you can do that:

Set the system property JAVA_VENDOR to value 'Sun' -> then the wl will be
started with Sun JDK and everything will be ok. Also the performance of the
server will be better.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo