Bug 63036 - Rename project folder check box doesn't work
Rename project folder check box doesn't work
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Projects UI
5.x
All All
: P2 (vote)
: 5.x
Assigned To: Jan Lahoda
issues@projects
: API, API_REVIEW_FAST
: 63236 63903 66455 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-25 10:54 UTC by Radko Najman
Modified: 2005-10-13 13:55 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Patch. (12.87 KB, patch)
2005-09-13 15:37 UTC, Jan Lahoda
Details | Diff
Commit log. (3.22 KB, text/plain)
2005-09-19 14:01 UTC, Jan Lahoda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Radko Najman 2005-08-25 10:54:49 UTC
"Also Rename Project Folder" check box in Rename Project dialog doesn't work.
The project folder is always renamed.
Comment 1 Radko Najman 2005-08-29 13:06:13 UTC
*** Issue 63236 has been marked as a duplicate of this issue. ***
Comment 2 Radko Najman 2005-08-29 13:06:19 UTC
*** Issue 63236 has been marked as a duplicate of this issue. ***
Comment 3 Jan Lahoda 2005-08-29 14:52:57 UTC
P2 I think.
Comment 4 Marian Mirilovic 2005-09-08 15:03:45 UTC
*** Issue 63903 has been marked as a duplicate of this issue. ***
Comment 5 Jan Lahoda 2005-09-13 15:35:57 UTC
In order to fix this bug, I would like to do a small change in sematic of
calling MoveOperationImplementation.notifyMoved and
CopyOperationImplementation.notifyCopied. The first argument of these methods is
original (source) project, and these methods are called on both original and
moved/copied project. Currently, the original project reference is passed for
both calls (for the original and new project). I would like to change this to
pass "null" as "original" when these methods are called on the original project.

I am attaching patch to fix this problem (from the API point of view).
Comment 6 Jan Lahoda 2005-09-13 15:37:33 UTC
Created attachment 24754 [details]
Patch.
Comment 7 Jesse Glick 2005-09-13 23:25:51 UTC
Sensible.

For style, prefer the condition

  if (original == null) {

to

  if (null == original) {

and so on.
Comment 8 mslama 2005-09-14 07:55:46 UTC
Jan "if (null == original)" is C style programming to avoid problems with typo
"original = null" instead of "original == null". Both conditions are valid in C
but they are different. In Java it is not necessary.
Comment 9 Petr Hrebejk 2005-09-14 13:27:27 UTC
For dev-rev: fine with me.
Comment 10 Tomas Zezula 2005-09-14 19:22:58 UTC
Seems good to me.
Comment 11 Radko Najman 2005-09-15 10:31:14 UTC
No objection from my side.
Comment 12 Jan Lahoda 2005-09-15 10:58:33 UTC
I would like to commit the change tomorrow, if there are no objections.
Comment 13 Jan Lahoda 2005-09-19 14:00:09 UTC
Hopefully fixed in the trunk. See attached log for more details.
Comment 14 Jan Lahoda 2005-09-19 14:01:57 UTC
Created attachment 24943 [details]
Commit log.
Comment 15 Jan Lahoda 2005-10-13 13:55:18 UTC
*** Issue 66455 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo