Bug 62897 - Rename test after renaming method
Rename test after renaming method
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: JUnit
5.x
All All
: P3 with 3 votes (vote)
: 7.4
Assigned To: junit-issues@java
junit-issues@java
: PLAN
: 225936 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-23 22:40 UTC by Jesse Glick
Modified: 2013-02-17 01:49 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2005-08-23 22:40:31 UTC
Would be nice if a rename refactoring for Foo.m1() -> Foo.m2() also offered to
rename FooTest.testM1() -> FooTest.testM2() if it existed. Would mean a dep
junit -> refactoring, I guess.
Comment 1 pribyl 2008-04-30 16:48:17 UTC

*** This issue has been marked as a duplicate of 52960 ***
Comment 2 Theofanis Oikonomou 2013-01-29 16:35:46 UTC
Bug 52960 was fixed but this is still valid.
Comment 3 Theofanis Oikonomou 2013-02-11 09:37:55 UTC
*** Bug 225936 has been marked as a duplicate of this bug. ***
Comment 4 mjr_1974 2013-02-11 13:55:05 UTC
The test method name can also exactly match the renamed test (usually with the @Test annotation).
It is annoying to hunt for the test method each time I rename a method. Think, for example, when you rename a method in an interface! The impact could be in many tests! For the IDE help keeping test and base code in sync should be a must!
Comment 5 Theofanis Oikonomou 2013-02-15 14:39:25 UTC
Changeset: f170236ded95
Author:    Theofanis Oikonomou <theofanis@netbeans.org>
Date:      2013-02-15 15:37
Message:   
Issue #62897 - Rename test after renaming method
Comment 6 Quality Engineering 2013-02-17 01:49:29 UTC
Integrated into 'main-golden', will be available in build *201302162300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/f170236ded95
User: Theofanis Oikonomou <theofanis@netbeans.org>
Log: Issue #62897 - Rename test after renaming method


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo