Bug 62818 - Cancelling Find Usages dialog leaves EQ blocked for a while
Cancelling Find Usages dialog leaves EQ blocked for a while
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Refactoring
5.x
All All
: P3 (vote)
: 5.x
Assigned To: Jan Becicka
issues@java
: PERFORMANCE, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-22 22:07 UTC by Jesse Glick
Modified: 2007-04-03 18:02 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2005-08-22 22:07:09 UTC
Sometimes when you invoke Find Usages, it can take a long time for it to enable
the components on the dialog; it just sits there for a while with only the
Cancel button enabled. But if you press Cancel, the dialog is closed, but then
the event queue is just blocked for the same amount of time it would have spent
to enable the components - i.e. it doesn't really cancel anything.

Should be fixed to

1. Show some progress meter while calculating whatever it needs to calculate to
enable the components in the FU dialog.

2. Have Cancel really stop this computation immediately.
Comment 1 Jan Becicka 2005-08-23 07:42:44 UTC
Problem probably is, that some MDR transaction is blocking EQ I suppose.
Comment 2 Jesse Glick 2005-08-23 11:36:56 UTC
Note that this freeze is a bit unusual for the IDE since it happens for a
limited amount of time, and if you did *not* press Cancel, the same pause would
occur with the EQ live (but interactions prevented by the dialog being up).

It is tricky to reproduce this since I have found that the initialization stage
for F.U. can be almost immediate if some internal cache is warmed up. Most
likely to be a long wait if you have a lot of modules open and are running F.U.
for the first time in this IDE session.

Whatever it is doing, a progress bar (or just some message "Initializing...")
would be appreciated, since if you are not familiar with it, it looks like
something is broken: the dialog comes up with most functionality disabled and no
indication that it will be enabled shortly.
Comment 3 Jan Becicka 2005-08-23 14:45:22 UTC
Checking in AbstractRefactoring.java;
/cvs/refactoring/src/org/netbeans/modules/refactoring/api/AbstractRefactoring.java,v
 <--  AbstractRefactoring.java
new revision: 1.26; previous revision: 1.25
done
Comment 4 Jesse Glick 2005-08-23 15:15:17 UTC
Did that commit actually fix the bug? It looks like you just added a progress
meter, which is OK (not as good as showing progress in the dialog itself), but I
think wouldn't address the problem of the EQ freeze after pressing Cancel.
Comment 5 Jan Becicka 2005-08-23 15:49:17 UTC
The commit adds progress indication. I'll must take a look at Cancel more closely.
Comment 6 Jan Becicka 2005-08-24 07:01:59 UTC
EQ is not blocked any more.
Checking in ParametersPanel.java;
/cvs/refactoring/src/org/netbeans/modules/refactoring/spi/ui/ParametersPanel.java,v
 <--  ParametersPanel.java
new revision: 1.18; previous revision: 1.17
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo