Bug 62699 - JUnit Test Results window does not have KB focus when displayed
JUnit Test Results window does not have KB focus when displayed
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: JUnit
5.x
All All
: P3 (vote)
: 5.x
Assigned To: Marian Petras
junit-issues@java
: FOCUS
: 67054 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-19 20:35 UTC by Jesse Glick
Modified: 2005-11-16 14:47 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2005-08-19 20:35:46 UTC
I'm not sure what you are doing wrong at the code level (maybe not using
requestFocusInWindow correctly from TopComponent?), but whenever the JUnit
Results window is shown when an Ant session w/ unit tests has run, it has no KB
focus, even though it is painted as selected. For example, Ctrl-Backspace does
not work to make it a sliding window. If you click inside the window with the
mouse, then it works.
Comment 1 Marian Petras 2005-09-15 16:03:36 UTC
Confirmed, accepted.
Comment 2 Marian Petras 2005-10-19 16:30:00 UTC
*** Issue 67054 has been marked as a duplicate of this issue. ***
Comment 3 Marian Petras 2005-11-16 14:47:04 UTC
This was fixed together with bug #64305 ("Not able to hide JUnit window with
keyboard").


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo