Bug 62472 - JBoss plugin doesn't recognize server status
JBoss plugin doesn't recognize server status
Status: CLOSED FIXED
Product: serverplugins
Classification: Unclassified
Component: JBoss
4.x
PC Windows XP
: P2 (vote)
: 5.x
Assigned To: Anna Bolotova
issues@serverplugins
42only
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-17 12:06 UTC by Jiri Skrivanek
Modified: 2006-03-24 12:59 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2005-08-17 12:06:38 UTC
On my WindowsXP I have installed JBoss 4.0.2 and when I add it to IDE and start
it, it looks like the server is not started. Simply IDE doesn't recognize status
of server. To reproduce:

- unzip jboss-4.0.2.zip into E:\Program Files\
- add 'set JAVA_HOME=E:\jdk1.5.0_04' to E:\Program Files\bin\run.bat
- start IDE
- add JBoss server in Runtime tab
- start JBoss server using popup menu Start on server node and wait until it is
running. Check external browser shows JBoss welcome page at http://localhost:8080/.
- look at popup menu of JBoss server node. There is Start item enabled and if
you run it, it throws port conflict exceptions.
- try Refresh on the node but it does nothing

Build 200508161800, JDK1.5.0_04, WindowsXP, JBoss4.0.2.
Comment 1 Petr Blaha 2005-08-17 15:21:10 UTC
This is strange, similar symptomps like in issue #61477. I think that this issue
is fixed in trunk. Jirko can you try to install NB 4.1 and JBoss nbm from
mentioned issue on your comp and test it? Thanks, Petr
Comment 2 Pavel Buzek 2005-08-18 15:52:36 UTC
This is a different problem then issue 61477. The probem is that Jirka has the
server installed in "C:\Program Files" (space in path). I can reproduce it if I
copy jboss there.
I will fix this for 4.2.
Comment 3 Petr Blaha 2005-08-18 16:09:03 UTC
Jirka Skrivanek confirmed that issue is caused by space in JBoss path.
Comment 4 Anna Bolotova 2005-08-31 10:18:46 UTC
Changed way to get URL.
Comment 6 Petr Jiricka 2005-09-01 14:15:04 UTC
I think a better fix would be to use the NbProcessDescriptor class, which
handles spaces in path well, instead of Runtime.getRuntime().exec().


Comment 7 Libor Kotouc 2005-09-09 12:26:00 UTC
Fixed in trunk.

Fix of JBStartServer (surrounding executed command with quotation marks) in
release41 branch does not work on linux. NbProcessDescriptor should be used.

Checking in JBDeploymentFactory.java;
/cvs/serverplugins/jboss4/src/org/netbeans/modules/j2ee/jboss4/JBDeploymentFactory.java,v
 <--  JBDeploymentFactory.java
new revision: 1.5; previous revision: 1.4
done
Checking in ide/JBStartServer.java;
/cvs/serverplugins/jboss4/src/org/netbeans/modules/j2ee/jboss4/ide/JBStartServer.java,v
 <--  JBStartServer.java
new revision: 1.19; previous revision: 1.18
done
Comment 8 Jiri Skrivanek 2005-09-14 12:02:45 UTC
Verified in build 200509131800.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo