Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 62337 - JVM Parameters (-javaagent) is ignored by JUnit
JVM Parameters (-javaagent) is ignored by JUnit
Status: RESOLVED DUPLICATE of bug 46298
Product: java
Classification: Unclassified
Component: JUnit
4.x
All All
: P3 (vote)
: TBD
Assigned To: junit-issues@java
junit-issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-16 00:54 UTC by matthiasmann
Modified: 2005-10-19 16:25 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description matthiasmann 2005-08-16 00:54:29 UTC
I'm writing an application that uses a java.lang.instrument agent (using the JVM
parameter "-javaagent:....." in the project properties). The application depends
the byte code modifications that are done by this agent.

I can run and debug the application without problems.
But when I try to run a JUnit test the javaagent is not loaded.
Comment 1 Marian Petras 2005-10-19 16:25:52 UTC
This is not currently possible. A request for making it possible is already
recorded - see issue #46298.

*** This issue has been marked as a duplicate of 46298 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo