Bug 62038 - module private packages are on classpath
module private packages are on classpath
Status: VERIFIED DUPLICATE of bug 59792
Product: apisupport
Classification: Unclassified
Component: Project
5.x
All All
: P3 (vote)
: 5.x
Assigned To: Martin Krauskopf
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-10 12:39 UTC by pzajac
Modified: 2005-09-05 09:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pzajac 2005-08-10 12:39:12 UTC
[200508091800]
Steps to reproduce:
1) Create Modules Suite SUITE
2) Create module M1 in SUITE (with package m1,the m1 package is not public)
3) Create module M2 in SUITE
4) Add module M1 to classpath M2
6) Add class C1 to m1 package 
7) Create class C2 in any package of M2

The C1 class is on classpath of C2. (It can be used in the file)
Comment 1 Jesse Glick 2005-08-10 17:02:06 UTC

*** This issue has been marked as a duplicate of 59792 ***
Comment 2 pzajac 2005-09-01 16:26:43 UTC
v


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo