Bug 61997 - Deadlock: NbJMIResultItem.ClassResultItem.instantSubstitution, BaseDocument.render, CompletionImpl.insertUpdate
Deadlock: NbJMIResultItem.ClassResultItem.instantSubstitution, BaseDocument.r...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Completion & Templates
5.x
All All
: P2 (vote)
: 5.x
Assigned To: Dusan Balek
issues@editor
: RANDOM, THREAD
: 61523 61827 62394 (view as bug list)
Depends on:
Blocks: 62442
  Show dependency treegraph
 
Reported: 2005-08-09 17:50 UTC by Jesse Glick
Modified: 2007-11-05 13:38 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (13.33 KB, text/plain)
2005-08-09 17:50 UTC, Jesse Glick
Details
Again, typing the same thing in the same class! (13.20 KB, text/plain)
2005-08-09 18:05 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2005-08-09 17:50:32 UTC
Randomly occurred in a recent dev build (Aug 08), Mustang b45, while typing code
in the editor. Data loss.
Comment 1 Jesse Glick 2005-08-09 17:50:49 UTC
Created attachment 23615 [details]
Thread dump
Comment 2 Jesse Glick 2005-08-09 18:05:19 UTC
Created attachment 23616 [details]
Again, typing the same thing in the same class!
Comment 3 Jesse Glick 2005-08-09 18:05:50 UTC
This is a real problem.
Comment 4 Martin Roskanin 2005-08-16 10:03:12 UTC
*** Issue 61523 has been marked as a duplicate of this issue. ***
Comment 5 Martin Roskanin 2005-08-16 10:04:37 UTC
should bw fixed for NB 4.2
(take care of all runInAWT calls in CompletionImpl...)
Comment 6 Martin Roskanin 2005-08-17 09:02:25 UTC
*** Issue 62394 has been marked as a duplicate of this issue. ***
Comment 7 Roman Strobl 2005-08-17 14:32:55 UTC
Marking this issue as future stopper for Q-Build candidate 200508161800 (there
are duplicates + dataloss). 
Comment 8 Martin Roskanin 2005-08-18 07:19:32 UTC
*** Issue 61827 has been marked as a duplicate of this issue. ***
Comment 9 Miloslav Metelka 2005-08-18 11:58:42 UTC
RP locks doc and tries completion lock.
AWT holds completion lock and tries document.
I'll try to resolve ASAP.
Comment 10 Roman Strobl 2005-08-18 12:07:19 UTC
Thanks - note it's not a q-build stopper but a future stopper (it doesn't block
the q-build). So you have time.
Comment 11 Miloslav Metelka 2005-08-18 13:27:54 UTC
I have a quick fix but I've entered issue 62569 for further inspection.
Fixed in main trunk:
Checking in src/org/netbeans/modules/editor/completion/CompletionImpl.java;
/cvs/editor/completion/src/org/netbeans/modules/editor/completion/CompletionImpl.java,v
 <--  CompletionImpl.java
new revision: 1.8; previous revision: 1.7
Comment 12 Miloslav Metelka 2005-08-18 13:32:15 UTC
Integrated quick fix into q-build branch QBE200508161800:
Checking in src/org/netbeans/modules/editor/completion/CompletionImpl.java;
/cvs/editor/completion/src/org/netbeans/modules/editor/completion/CompletionImpl.java,v
 <--  CompletionImpl.java
new revision: 1.7.4.1; previous revision: 1.7
Comment 13 Roman Strobl 2005-08-22 10:04:13 UTC
Future q-build stoppers don't need to be integrated to the q-build branch.
Nevermind, let's leave it the way it is. Leaving verification on Jesse. 
Comment 14 Jesse Glick 2005-08-22 21:39:28 UTC
I have no way of verifying.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo