Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 61895 - The deployment descriptor has to be specified in the wizard
The deployment descriptor has to be specified in the wizard
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Web Freeform
5.x
All Linux
: P3 (vote)
: 6.x
Assigned To: Radko Najman
issues@javaee
:
: 55783 (view as bug list)
Depends on:
Blocks: 54125 65184 81526 89479
  Show dependency treegraph
 
Reported: 2005-08-07 16:47 UTC by Petr Pisl
Modified: 2007-04-18 17:35 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Pisl 2005-08-07 16:47:28 UTC
When you create new web freeform, there is expected, that the deployment
descriptor is under WebPages/WEB-INF folder. A lot of projects has deployment
descriptor outside the Web Pages and because the bulk of the features need to
know, where the deployment descriptor is located, there should be a way how to
set up the location.
Comment 1 Radko Najman 2005-08-08 08:20:00 UTC
It shouldn't be hard to do it for 4.2.
Comment 2 Petr Jiricka 2005-09-12 09:23:59 UTC
See also a similar issue 64088 for standard (non-freeform) projects.
Comment 3 Radko Najman 2005-11-03 14:57:03 UTC
Will be addressed in next release.
Comment 4 Radko Najman 2007-02-18 17:59:16 UTC
*** Issue 55783 has been marked as a duplicate of this issue. ***
Comment 5 Radko Najman 2007-04-18 17:32:31 UTC
Implemented.

Checking in
src/org/netbeans/modules/web/freeform/resources/freeform-project-web.xsd;
/cvs/web/freeform/src/org/netbeans/modules/web/freeform/resources/freeform-project-web.xsd,v
 <--  freeform-project-web.xsd
new revision: 1.5; previous revision: 1.4
done
Checking in nbproject/project.xml;
/cvs/web/freeform/nbproject/project.xml,v  <--  project.xml
new revision: 1.18; previous revision: 1.17
done
Checking in src/org/netbeans/modules/web/freeform/ui/WebLocationsWizardPanel.java;
/cvs/web/freeform/src/org/netbeans/modules/web/freeform/ui/WebLocationsWizardPanel.java,v
 <--  WebLocationsWizardPanel.java
new revision: 1.5; previous revision: 1.4
done
Checking in src/org/netbeans/modules/web/freeform/ui/WebLocationsPanel.form;
/cvs/web/freeform/src/org/netbeans/modules/web/freeform/ui/WebLocationsPanel.form,v
 <--  WebLocationsPanel.form
new revision: 1.6; previous revision: 1.5
done
Checking in src/org/netbeans/modules/web/freeform/ui/Bundle.properties;
/cvs/web/freeform/src/org/netbeans/modules/web/freeform/ui/Bundle.properties,v 
<--  Bundle.properties
new revision: 1.13; previous revision: 1.12
done
Checking in
src/org/netbeans/modules/web/freeform/ui/NewWebFreeformProjectWizardIterator.java;
/cvs/web/freeform/src/org/netbeans/modules/web/freeform/ui/NewWebFreeformProjectWizardIterator.java,v
 <--  NewWebFreeformProjectWizardIterator.java
new revision: 1.8; previous revision: 1.7
done
Checking in src/org/netbeans/modules/web/freeform/ui/WebLocationsPanel.java;
/cvs/web/freeform/src/org/netbeans/modules/web/freeform/ui/WebLocationsPanel.java,v
 <--  WebLocationsPanel.java
new revision: 1.11; previous revision: 1.10
done
Checking in src/org/netbeans/modules/web/freeform/Bundle.properties;
/cvs/web/freeform/src/org/netbeans/modules/web/freeform/Bundle.properties,v  <--
 Bundle.properties
new revision: 1.10; previous revision: 1.9
done
Checking in src/org/netbeans/modules/web/freeform/WebModules.java;
/cvs/web/freeform/src/org/netbeans/modules/web/freeform/WebModules.java,v  <-- 
WebModules.java
new revision: 1.13; previous revision: 1.12
done
Checking in src/org/netbeans/modules/web/freeform/WebProjectGenerator.java;
/cvs/web/freeform/src/org/netbeans/modules/web/freeform/WebProjectGenerator.java,v
 <--  WebProjectGenerator.java
new revision: 1.9; previous revision: 1.8
done
Comment 6 Radko Najman 2007-04-18 17:35:01 UTC
... and

Checking in deps.txt;
/cvs/ide/golden/deps.txt,v  <--  deps.txt
new revision: 1.544; previous revision: 1.543
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo