Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 61334 - Navigator should play nicely with the palette
Navigator should play nicely with the palette
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Palette
5.x
All All
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
OSLO
:
: 69471 74736 (view as bug list)
Depends on:
Blocks: 93713
  Show dependency treegraph
 
Reported: 2005-07-25 10:19 UTC by Jan Lahoda
Modified: 2008-12-22 11:50 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Lahoda 2005-07-25 10:19:20 UTC
Recent sources of the core/palette and core/navigator (from the navigator_58819
branch).

I have a (text) editor which provides content into both palette and navigator.
The problem is that when I select the palette, the content of the navigator
disappears. I think that the navigator's content should survive focus change
into the palette.
Comment 1 Marian Mirilovic 2006-01-03 10:54:09 UTC
Too late for NB5.0, please reevaluate.
Comment 2 David Simonek 2006-04-10 17:20:46 UTC
*** Issue 74736 has been marked as a duplicate of this issue. ***
Comment 3 David Simonek 2006-04-10 17:21:22 UTC
Be sure to see 74736 for more info.
Comment 4 Jiri Kopsa 2006-04-23 16:29:14 UTC
This issue does not only apply to text editing (as highlighted in the intial
comment of this issue), but has also fundamental impact on Orchestration
Designer of the NB Enterprise Pack. Morover, as we proceed with integrating
Inspector and Navigator, we may want to have DnD from palette to
navigator/inspector also in GUI Builder. All these might be considered as an
efficiency improvement for the expert users. However the predictability of such
an interaction seems to be a significant improvement and thus we think the
feature is quite important. 

What is the earliest possible timeframe for the fix?
Comment 5 David Simonek 2007-03-14 20:40:26 UTC
fixed along with 93711 in main trunk:

Checking in src/org/netbeans/modules/navigator/NavigatorController.java;
/cvs/core/navigator/src/org/netbeans/modules/navigator/NavigatorController.java,v
 <--  NavigatorController.java
new revision: 1.17; previous revision: 1.16
done
Checking in test/unit/src/org/netbeans/modules/navigator/NavigatorTCTest.java;
/cvs/core/navigator/test/unit/src/org/netbeans/modules/navigator/NavigatorTCTest.java,v
 <--  NavigatorTCTest.java
new revision: 1.7; previous revision: 1.6
done
Checking in test/unit/src/org/netbeans/modules/navigator/ProviderRegistryTest.java;
/cvs/core/navigator/test/unit/src/org/netbeans/modules/navigator/ProviderRegistryTest.java,v
 <--  ProviderRegistryTest.java
new revision: 1.5; previous revision: 1.4
done
Checking in
test/unit/src/org/netbeans/modules/navigator/resources/testCorrectCallsOfNavigatorPanelMethodsLayer.xml;
/cvs/core/navigator/test/unit/src/org/netbeans/modules/navigator/resources/testCorrectCallsOfNavigatorPanelMethodsLayer.xml,v
 <--  testCorrectCallsOfNavigatorPanelMethodsLayer.xml
new revision: 1.4; previous revision: 1.3
done
Checking in src/org/netbeans/spi/navigator/NavigatorPanel.java;
/cvs/core/navigator/src/org/netbeans/spi/navigator/NavigatorPanel.java,v  <-- 
NavigatorPanel.java
new revision: 1.4; previous revision: 1.3
done
Checking in arch.xml;
/cvs/core/navigator/arch.xml,v  <--  arch.xml
new revision: 1.11; previous revision: 1.10
done
Comment 6 David Simonek 2007-03-21 18:15:30 UTC
*** Issue 69471 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo