Bug 61301 - Set focus to the first property after the first invocation of Property Sheet
Set focus to the first property after the first invocation of Property Sheet
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Explorer
5.x
All All
: P4 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@platform
buzz_patch_candidate, release41_fixes...
: A11Y, FOCUS, UI
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-22 17:32 UTC by Girish Balachandran
Modified: 2010-10-27 14:26 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Girish Balachandran 2005-07-22 17:32:31 UTC
How to reproduce:
-Right click on any node in the Project or Filesystem tree, 
-choose Properties
-Netbeans property sheet window/dialog appears (with name "**** - Properties")
-try to start tab traversal of the components on this window by pressing "tab" key
-none of the components can be reached

However, click on one of the properties and then press the tab key, all the
components can be traversed from them on.

The fix could be, put the default focus on the first property in the properties
window.
Comment 1 Marian Mirilovic 2005-07-25 09:33:26 UTC
P2? 
Comment 2 pgebauer 2005-08-07 13:18:36 UTC
I think, this is not a bug. When the property sheet window/dialog appears, the
PropertySheet table has focus. When a user wants to move out from the
PropertySheet table, Ctrl-Tab must be pressed. PSheet (description area below
PropertySheet table) gets focus after that. A user can use Tab or Ctrl-Tab now
for focus movement to Close button and to PropertySheet table (in cycle). When a
user wants to move from the PropertySheet table, Ctrl-Tab must be pressed again.
When the PropertySheet table has focus and user wants to move inside the
PropertySheet table, Arrow-Down or Arrow-Up must be pressed. When a table row
has focus, Tab or Arrow-Down can be used for movement to next row and Shift-Tab
or Arow-Up can be used for movement to previous row.

Could somebody from openide evaluate my opinion? Thanks.
Comment 3 Martin Krauskopf 2005-08-09 11:43:06 UTC
It would be a nice enhancement if the first property has a focus after the first
invocation. So confusion with TAB would disappear + maybe another minor tuning.
Also I'm not sure if there is not any behaviour required by HIE.
I believe that the behaviour described by Petr is clear and intuitive enough -
I'm also using almost keyboard only.
Feel free to reassign Petr ;)
Comment 4 Jan Chalupa 2005-08-09 11:51:36 UTC
Petr's evaluation is correct. Ctrl-Tab must be used, because the property sheet
table component consumes Tab. This behavior is by design.
Comment 5 Jaromir Uhrik 2009-05-11 10:55:08 UTC
Ctrl+Tab seems to me like a workaround. But I agree with mkrauskopf - to have a focus at the first property.
Comment 6 Jaromir Uhrik 2009-05-12 12:15:31 UTC
Sorry, I have wrongly written Ctrl+Tab instead of "Tab". So that to workaround this bug just push "Tab" when new propertysheet is opened.
Comment 7 Jaromir Uhrik 2010-10-27 14:26:18 UTC
After former changes in code it seems to be fixed now - I cannot reproduce this problem in latest release 6.9.1. Marking issue as resolved.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo