Bug 61083 - Multiple clipboards, as in xemacs "registers"
Multiple clipboards, as in xemacs "registers"
Status: RESOLVED DUPLICATE of bug 56401
Product: editor
Classification: Unclassified
Component: -- Other --
5.x
All All
: P3 (vote)
: TBD
Assigned To: Milutin Kristofic
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-18 15:18 UTC by edburns
Modified: 2012-07-17 12:03 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description edburns 2005-07-18 15:18:00 UTC
One of the most useful features of xemacs is the register feature.  A register
is a virtual clipboard, assigned to a key, that can hold either text, or the
cursor location.  There are commands to save the current selection, or the
current cursor location to a register.  Likewise, there are commands to paste
the contents of a register into the current cursor location, or cause the cursor
to jump to the location stored in the register.  

There are as many registers as there are glyphs on the keyboard.  That is, A and
a are separete registers.
Comment 1 edburns 2005-07-18 16:19:47 UTC
It must be possible to pre-populate the registers from a file.  For example, I'd
like to have a set of registers loaded with html elements to ease javadoc authoring.
Comment 2 Vitezslav Stejskal 2007-11-05 13:31:08 UTC
Moving to the 'other' subcomponent.
Comment 3 Milutin Kristofic 2012-07-17 12:03:30 UTC

*** This bug has been marked as a duplicate of bug 56401 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo