Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 61050 - tooltips for classes/methods/variables
tooltips for classes/methods/variables
Status: RESOLVED DUPLICATE of bug 95691
Product: java
Classification: Unclassified
Component: Editor
6.x
All All
: P1 with 5 votes (vote)
: TBD
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-15 21:45 UTC by gapon
Modified: 2012-11-28 22:22 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gapon 2005-07-15 21:45:09 UTC
hi,
i really miss one feature in netbeans - when i put mouse over
class/method/variable - no tooltip is shown
(in eclipse, you can see definiton and javadoc)

and one more thing - when there is an error in file, no hints are available
(in eclipse, you can press <ctrl> + 1)

thanks for your great work!
Comment 1 alexd 2007-07-26 06:06:37 UTC
This is a great feature in Visual Studio as well.  It's very convenient to be able to mouseover words and have 
tooltips appear with type information.  This feature is also very helpful when tracing through another developers code 
without having to jump up to the parameter, variable, import, etc. declaration.

Updated this issue to version 6.
Comment 2 Jiri Prox 2007-07-26 09:52:31 UTC
This is partially implemented. It does not work for moused hovering but it shows javadoc and declaration of symbol under
caret
Comment 3 markiewb 2012-11-28 22:22:44 UTC

*** This bug has been marked as a duplicate of bug 95691 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo