Bug 61023 - I18N - how to set encoding of non-java file edited by netbeans?
I18N - how to set encoding of non-java file edited by netbeans?
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: -- Other --
5.x
All All
: P3 with 1 vote (vote)
: TBD
Assigned To: Milutin Kristofic
issues@editor
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-15 11:36 UTC by evzhy
Modified: 2016-07-07 07:30 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description evzhy 2005-07-15 11:36:53 UTC
Hello, my project use the stupid preprocessor #if #else etc, the file name is *.jpp
When I edit .jpp file in netbeans, I input Chinese words, and save, and compile.
I get warning 'utf-8 can not recognize char', and I open the created .java file,
the string should be Chinese words is worng! it is blank string! 
It seems that only the .java file can set encoding in Tools | Options | Editing
| Java Source. But how to set non-java file 's encoding ?
Comment 1 Ken Frank 2006-07-13 23:25:23 UTC
maybe a silly question, but are you running in Chinese locale when running nb ?
also, can you attach a gif of what editor looks like with java file and also
the .jpp file, and tell what specific platform and locale you are running in ?

ken.frank@sun.com
Comment 2 evzhy 2006-07-14 06:56:48 UTC
yes, I run netbeans in Chinese locale

I hope it is free to set encoding of any file in netbeans, not only .java file.

Comment 3 Martin Balin 2016-07-07 07:30:43 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo