Bug 60968 - IDE help display nothing
IDE help display nothing
Status: RESOLVED WONTFIX
Product: ide
Classification: Unclassified
Component: Code
5.x
PC Windows XP
: P3 (vote)
: TBD
Assigned To: jouko
issues@ide
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-14 11:55 UTC by alvinsw
Modified: 2008-01-15 11:28 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
changes in nokia manifest file (900 bytes, patch)
2005-09-26 11:04 UTC, Martin Ryzl
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description alvinsw 2005-07-14 11:55:29 UTC
Help -> Help Contents
The IDE Help window is shown but the content is empty.
I have the Index list, but cannot click any of them.
Cannot search as well.
I installed Mobility pack and Nokia Developer Suite before I noticed the error.
Comment 1 Martin Ryzl 2005-07-15 22:53:21 UTC
This is not a bug in the IDE but in NDS. NDS 3.0 comes with own version of
javahelp (Spec version 1.0, Impl. version 1.1.3) and adds it on classpath in
manifest of NDS_Adapter_NetBeans.jar. It seems they need access to jh api. It
causes clash with default NetBeans javahelp. Correct solution would be Nokia
module depending on org-netbeans-modules-javahelp.jar as it has javax.help in
public packages. I'm afraid there is no workaround or hotfix other than fix on
Nokia side. Also other 3rd party modules may cause such problem.
Comment 2 Martin Ryzl 2005-09-26 11:02:04 UTC
Here is a workaround:
1. find nokia/modules/NDS_Adapter_NetBeans.jar in netbeans installation directory.
2. update the manifest file - patch is attached. Note that NDS may be installed
in different location than mine - you may need to upate patch accordingly.
Comment 3 Martin Ryzl 2005-09-26 11:04:16 UTC
Created attachment 25163 [details]
changes in nokia manifest file
Comment 4 Martin Ryzl 2005-11-24 12:23:16 UTC
I've already reported the problem to Nokia. Also I'm closing the issue as
WONTFIX because I think there is nothing we can do on our side.
Comment 5 Marian Mirilovic 2006-08-15 08:28:45 UTC
clear resolution
Comment 6 Marian Mirilovic 2006-08-15 08:29:05 UTC
resolved wontfix


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo