Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 60731 - java.net.MalformedURLException when doubleclick on .NBM file in Files view
java.net.MalformedURLException when doubleclick on .NBM file in Files view
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
5.x
All All
: P3 (vote)
: 5.x
Assigned To: Jiri Rechtacek
issues@platform
:
: 63506 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-04 14:59 UTC by Jaromir Uhrik
Modified: 2005-09-06 09:07 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2005-07-04 14:59:39 UTC
[200507031800; jdk1.4.2]
Doubleclick on .nbm in Files view causes following exception:

java.net.MalformedURLException: no protocol: 
	at java.net.URL.<init>(URL.java:537)
	at java.net.URL.<init>(URL.java:434)
	at java.net.URL.<init>(URL.java:383)
	at
org.netbeans.modules.autoupdate.ModuleUpdate.createFromDistribution(ModuleUpdate.java:471)
	at
org.netbeans.modules.autoupdate.ModuleUpdate.getModuleUpdate(ModuleUpdate.java:264)
	at
org.netbeans.modules.autoupdate.XMLUpdates.checkDownloadedModules(XMLUpdates.java:298)
	at org.netbeans.modules.autoupdate.XMLUpdates.go(XMLUpdates.java:162)
	at org.netbeans.modules.autoupdate.XMLUpdates.access$400(XMLUpdates.java:39)
[catch] at org.netbeans.modules.autoupdate.XMLUpdates$1.run(XMLUpdates.java:149)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:454)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:234)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:178)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:170)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
Comment 1 Jiri Rechtacek 2005-07-07 14:15:55 UTC
Not reproducible of my custom build 050707. Are you able to reproduce it on your
comp still?


>System Info: 
  Product Version       = NetBeans IDE Dev (Build 050707)
  Operating System      = Linux version 2.4.20-9 running on i386
  Java; VM; Vendor      = 1.4.2_06; Java HotSpot(TM) Client VM 1.4.2_06-b03; Sun
Microsystems Inc.
Comment 2 Jaromir Uhrik 2005-07-07 15:16:29 UTC
Jirko I am able to reproduce this issue, but now I see it is related to this
concrete project:
http://blogs.sun.com/roller/resources/roumen/GoogleFight.zip
Just unzip, open, build and make NBM. Then in files view doubleclick on the
builded .nbm and the exception appears. 
Sorry for generalization in the original report.
Comment 3 Jiri Rechtacek 2005-07-07 15:52:56 UTC
Checking in autoupdate/src/org/netbeans/modules/autoupdate/ModuleUpdate.java;
/cvs/autoupdate/src/org/netbeans/modules/autoupdate/ModuleUpdate.java,v  <-- 
ModuleUpdate.java
new revision: 1.60; previous revision: 1.59
done
Comment 4 Jaromir Uhrik 2005-07-12 09:23:51 UTC
Verified in dev build #200507110943.
Comment 5 Jiri Rechtacek 2005-09-06 09:07:56 UTC
*** Issue 63506 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo