Bug 60368 - Don't delete uninstalled modules
Don't delete uninstalled modules
Status: VERIFIED WONTFIX
Product: platform
Classification: Unclassified
Component: Autoupdate
5.x
All All
: P3 with 1 vote (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
:
: 101092 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-22 08:53 UTC by Jaromir Uhrik
Modified: 2010-10-13 12:32 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2005-06-22 08:53:49 UTC
This enhancement is related to issue #20323.
Uninstalled modules should not be deleted. They should be stored by side so that:
-they can be used by another user (when NetBeans started with clear userdir)
-the user can specify whether the module is intended to be disabled in current
userdir/global
-the undo of uninstall can be supported
Comment 1 Marian Mirilovic 2005-06-22 09:28:22 UTC
Probably we need something like specification, what happen if you uninstall
module when you :
- have installed it Global
- have installed it Local

as well as to decide what will happen with uninstalled module (delete,store on
the another place, ....)
Comment 2 Jiri Rechtacek 2008-04-10 09:14:44 UTC
*** Issue 101092 has been marked as a duplicate of this issue. ***
Comment 3 Antonin Nebuzelsky 2008-11-14 15:32:55 UTC
Reassigning to the new "autoupdate/*" owner dlipin.
Comment 4 Jaroslav Tulach 2010-10-13 12:01:22 UTC
I have no plans to do anything about this in foreseeable days.
Comment 5 Jaromir Uhrik 2010-10-13 12:32:14 UTC
Just one vote in this issue -> marking as Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo