Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 60256 - Removing mis-placed library causes exception
Removing mis-placed library causes exception
Status: RESOLVED DUPLICATE of bug 60313
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
5.x
All All
: P3 (vote)
: 5.x
Assigned To: issues@projects
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-20 10:12 UTC by dynamite
Modified: 2005-09-05 10:10 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dynamite 2005-06-20 10:12:15 UTC
Using latest development build: 200506191800
JDK: 1.6.0-ea-b39
Platform: WXP SP2

Added a library as a project source dependency (adding test dependencies seem
okay). However, the project doesn't have a dependency to this library. I
therefore remove the library and get the following exception:

    java.lang.InterruptedException
	at java.lang.Object.wait(Native Method)
	at java.lang.Object.wait(Object.java:484)
[catch] at org.openide.util.Mutex$QueueCell.sleep(Mutex.java:1388)
	at org.openide.util.Mutex.enter(Mutex.java:608)
	at org.openide.util.Mutex.readEnter(Mutex.java:488)
	at org.openide.util.Mutex.readAccess(Mutex.java:231)
	at org.netbeans.api.project.ProjectManager.findProject(ProjectManager.java:179)
	at
org.netbeans.modules.projectapi.SimpleFileOwnerQueryImplementation.getOwner(SimpleFileOwnerQueryImplementation.java:64)
	at org.netbeans.api.project.FileOwnerQuery.getOwner(FileOwnerQuery.java:68)
	at
org.netbeans.modules.java.project.ProjectSourceLevelQueryImpl.getSourceLevel(ProjectSourceLevelQueryImpl.java:31)
	at
org.netbeans.api.java.queries.SourceLevelQuery.getSourceLevel(SourceLevelQuery.java:46)
	at org.netbeans.modules.javacore.JMManager.getSourceLevel(JMManager.java:1087)
	at org.netbeans.modules.javacore.JMManager.getRootURI(JMManager.java:1093)
	at org.netbeans.modules.javacore.JMManager.cleanUpCodebases(JMManager.java:820)
	at org.netbeans.modules.javacore.JMManager.access$500(JMManager.java:59)
	at org.netbeans.modules.javacore.JMManager$4.run(JMManager.java:1180)
	at org.openide.util.Task.run(Task.java:207)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:435)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:836)
Comment 1 Jesse Glick 2005-06-27 08:05:17 UTC

*** This issue has been marked as a duplicate of 60313 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo