Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 59874 - Cannot run in 4.xxx junit tests created in 3.xxx
Cannot run in 4.xxx junit tests created in 3.xxx
Status: RESOLVED DUPLICATE of bug 46886
Product: projects
Classification: Unclassified
Component: Ant Freeform
4.x
All All
: P3 (vote)
: 5.x
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-11 10:07 UTC by olivieryolene
Modified: 2005-09-05 09:50 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description olivieryolene 2005-06-11 10:07:22 UTC
Hello,
I used to developp plenty of junit tests in Netbeans 3.xx, one for each java 
classes of my project.

After migration in netbeans 4., I am not able to run my junit tests any more.

I migrated my project this way :

Root
   web directory
      docroot
         my jsps

   source-code directory
      src
        com.mycompany.mypackage.myclass

      srcTest
        com.mycompany.mypackage.myclassTest   <==== my test case

From this free-form project :
  1/  I select myclassTest
  2/  I try to use <Ctrl-Alt-L> (as in Netbeans 3.) : does not work
  3/  I try to use : Menu Run/Run other/Test file : everything is grey in "Run 
other" submenu.

How can I run my tests again in 4. I have no other means than to run netbeans 
3.xxx to run my tests.

Please help. Thanks in advance,
Olivier
Comment 1 Jesse Glick 2005-06-24 11:08:07 UTC
Currently I think you need to write an Ant target to run the tests, if you are
using a freeform project. Check the online help for details, and use
nbusers@netbeans.org.

*** This issue has been marked as a duplicate of 46886 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo