Bug 59835 - IDE hangs when installing "Dialogs API" module
IDE hangs when installing "Dialogs API" module
Status: VERIFIED FIXED
Product: updatecenters
Classification: Unclassified
Component: AU Masters
5.x
All All
: P1 (vote)
: 5.x
Assigned To: rbalada
Autoupdate Masters
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-10 14:00 UTC by Jaromir Uhrik
Modified: 2005-09-05 10:06 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log attached (24.29 KB, text/plain)
2005-06-10 14:01 UTC, Jaromir Uhrik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2005-06-10 14:00:36 UTC
[200506091800; jdk1.5.0_04]
1.Run IDE with clear userdir
2.Start Update Center wizard
3.Set proxy and press Next
4.Select "Dialogs API" in "Infrastructure" category and follow the installation
When the ide restarts the neverending loop of exceptions is written in the
console . See the attached ide.log - the repeating blocks of errors were removed
from the end of the logfile.
Comment 1 Jaromir Uhrik 2005-06-10 14:01:37 UTC
Created attachment 22606 [details]
messages.log attached
Comment 2 Jiri Rechtacek 2005-06-13 12:54:56 UTC
Not problem of AutoUpdate module. Sure it's a wrong content of Dev Update Center.
If the build contains the openide.jar from DialogsAPI's NBM then the lookup
cannot be initialized:
java.lang.ExceptionInInitializerError
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
	at java.lang.Class.newInstance0(Class.java:350)
	at java.lang.Class.newInstance(Class.java:303)
	at
org.openide.util.lookup.MetaInfServicesLookup$P.getInstance(MetaInfServicesLookup.java:406)
	at org.openide.util.lookup.AbstractLookup$R.allInstances(AbstractLookup.java:875)
	at org.openide.util.lookup.ProxyLookup$R.computeResult(ProxyLookup.java:435)
	at org.openide.util.lookup.ProxyLookup$R.allInstances(ProxyLookup.java:388)

becausejava.lang.ExceptionInInitializerError
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
	at java.lang.Class.newInstance0(Class.java:350)
	at java.lang.Class.newInstance(Class.java:303)
	at
org.openide.util.lookup.MetaInfServicesLookup$P.getInstance(MetaInfServicesLookup.java:406)
	at org.openide.util.lookup.AbstractLookup$R.allInstances(AbstractLookup.java:875)


Jardo, what do you advise?
Comment 3 Jiri Rechtacek 2005-06-13 17:02:33 UTC
Eval: Caused by a relict openide.nbm. I have been promised it'll be deleted from
Dev UC. Rudo, thanks for it.
Comment 4 rbalada 2005-06-13 22:23:27 UTC
I've removed openide.nbm from cache and recreated catalog. I already did some
manual changes to the cache today, so I have to wait for next successful build
of daily-alpha-nbms moduleconfig to reload the cache from scratch from fresh new
build.
Comment 5 rbalada 2005-06-13 22:33:57 UTC
Oops. I forgot to mention this issue with openide dialogs is fixed. I keep this
issue open, because the very very root cause is still in effect and I have to
reload the Dev update center with NBMs from new build to override the effect.
Comment 6 rbalada 2005-08-24 09:26:16 UTC
Fixed
Comment 7 Jaromir Uhrik 2005-08-26 09:50:50 UTC
Verified in daily build #200508251800. Dialogs API is not present in
Infrastructure category now.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo