Bug 57212 - Call Web Service Operation is disabled
Call Web Service Operation is disabled
Status: VERIFIED DUPLICATE of bug 57202
Product: webservices
Classification: Unclassified
Component: Code
4.x
All All
: P3 (vote)
: 4.x
Assigned To: _ pcw
issues@webservices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-30 16:11 UTC by sigalduek
Modified: 2005-11-24 12:22 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sigalduek 2005-03-30 16:11:31 UTC
After adding web service client to my web project , I created a new java class.
Right click on the editor pop-up the menu which allows me to click on "Web
Service Client Resources".However the "Call Web Service Operation" is disabled.
Comment 1 _ pcw 2005-03-30 17:50:03 UTC
A couple of things: First, the operation is only currently valid within the
scope of an existing method.  So make sure that you are right clicking inside a
method body, or it will be disabled.  (We could enhance this, but I'm not sure
there is time.)

Second, the first time the menu item is invoked, especially if not much other
webservice activity has occurred within this IDE session, lazy
enabling/disabling of the menu combined with lazy loading of dependent code can
cause a brief delay the first time.  Second and later times should be better.

Please check to see if you are encountering any of the above behavior.  If not,
I need more details, such as does this happen in any type of source file, any
location within that source file, any service, etc.
Comment 2 sigalduek 2005-03-31 10:19:34 UTC
Project webApplication1 is attached.I'll describe the current situation:
Open java source file NewClass (reside at default package).
Under the mehod sample , right click the pop-up menu appears,selecting web
Services client Resources.Now the operation "call web service operation" is
enabled. The "Select Operation to Invoke" menu is opened and I picked the 
"DOTSGeoPhone" web service and the getPhoneinfo method. Nothing happend. There
is no generated code (I wait for more then 1 minute).I could not notice any CPU
activity either. However, after 2 minutes I tried the same scenario again but
the "Select Operation to Invoke" menu did not appear and the IDE was stuck (I
need to stop the IDE task from the winodw's task manager)
Comment 3 Martin Grebac 2005-03-31 10:25:00 UTC

*** This issue has been marked as a duplicate of 57202 ***
Comment 4 Lukas Jungmann 2005-11-24 12:22:39 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo