Bug 56885 - Debugger does not stop at the beginning of websvc after pressing F7
Debugger does not stop at the beginning of websvc after pressing F7
Status: VERIFIED WONTFIX
Product: javaee
Classification: Unclassified
Component: Debugger
4.x
All Windows XP
: P3 (vote)
: 5.x
Assigned To: Libor Kotouc
issues@javaee
: RELNOTE
: 69092 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-23 17:58 UTC by Lukas Jungmann
Modified: 2006-06-07 16:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
enterprise app (32.29 KB, application/x-compressed)
2005-03-23 17:58 UTC, Lukas Jungmann
Details
web app (14.29 KB, application/x-compressed)
2005-03-23 17:59 UTC, Lukas Jungmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Jungmann 2005-03-23 17:58:23 UTC
[build 200503221900]

1. open attached projects
2. run EnterpriseApplication1 and add web service from WebApplication2 to
webservice registry
3. put breakpoints:
 - on line 36 in srv.NewServlet in WebApplication3
 - on line 20 in ws.MyWSImpl in WebApplication2
4. debug WebApplication3 project (WebApp2 sources should be marked as "use for
debugging", if not, mark them for use)
5. goto http://localhost:8080/WebApplication3/NewServlet and back to IDE, you're
on line 36 in servlet
6. 12x press F7, you're on line 38 in servlet, now press F7 again

=> you should be on line 19 in ws.MyWSImpl, but you're on line 20 (where is the
breakpoint set)

7. press F7 again

=> you should be again on line 38 in servlet, but the debugger completes the request


BTW: You can randomly see no response from debugger for some longer time
Comment 1 Lukas Jungmann 2005-03-23 17:58:59 UTC
Created attachment 21075 [details]
enterprise app
Comment 2 Lukas Jungmann 2005-03-23 17:59:28 UTC
Created attachment 21076 [details]
web app
Comment 3 Libor Kotouc 2005-03-28 19:17:36 UTC
I tested it a few weeks ago, there are missing class loaded event or something
like this. The event is raised first time when JVM reaches breakpoint, all lines
before it are ignored for stepping.
Must be explored a little bit deeply.

Anyway, the problem is somewhere in JPDA debugger or JVM itself.
Comment 4 Martin Grebac 2005-03-29 08:37:03 UTC
Libore, please reevaluate. When bug is evaluated, it should be clear which
component is wrong, if the case is a corner case, or covers more general
problems (and should be upgraded to P2, moved to different component for
evaluation, ...).
Comment 5 Libor Kotouc 2005-03-30 14:14:11 UTC
WS client thread is other than WS thread and it implies that we are not able to
set STEP_INTO/STEP_OVER request to JVM because this request is tied with a thread.

There is still possibility to somehow detect 'remote' WS method and set hidden
breakpoint to the first line when user performs step-into action.

Target milestone set to promo-F.
Comment 6 Libor Kotouc 2005-11-22 14:17:40 UTC
*** Issue 69092 has been marked as a duplicate of this issue. ***
Comment 7 Petr Blaha 2006-03-13 13:48:10 UTC
TM 5.0 -> TBD
Comment 8 Libor Kotouc 2006-06-07 15:21:30 UTC
Lukas Jungmann and Martin Grebac agreed to close it as WONTFIX because the right
solution is hard to find, if it exists at all, and the workaround on the other
hand is really trivial.
Comment 9 Lukas Jungmann 2006-06-07 16:56:57 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo