Bug 56696 - Deadlock after clicking OK in project customizer
Deadlock after clicking OK in project customizer
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Project
4.x
All All
: P1 (vote)
: 4.x
Assigned To: Tomas Zezula
issues@java
: RANDOM, THREAD
: 56200 (view as bug list)
Depends on:
Blocks: 56754
  Show dependency treegraph
 
Reported: 2005-03-20 20:30 UTC by Jaroslav Tulach
Modified: 2005-09-14 13:30 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (16.19 KB, text/plain)
2005-03-20 20:31 UTC, Jaroslav Tulach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2005-03-20 20:30:31 UTC
The ide just deadlocked after I opened project customizer, selected debug
info-true and warn deprecations-true. Then OK and the deadlock appeared.
Comment 1 Jaroslav Tulach 2005-03-20 20:31:00 UTC
Created attachment 20966 [details]
thread dump
Comment 2 Jesse Glick 2005-03-21 10:42:09 UTC
I think javacore.MCPI should not be acquiring a new lock in a listener callback,
but perhaps it is something subtler than that. (Tomas, any ideas?)
Comment 3 Martin Matula 2005-03-21 13:50:10 UTC
Tomas, please help - I have no idea how to fix this. I am not even sure if it is
really our fault - reassigning to java/j2seproject for evaluation. It seems like
a bad lock ordering between project mutex and SourcePathImplementation.
Comment 4 Tomas Zezula 2005-03-21 14:07:57 UTC
OK, I will try to take a look on it.
Thanks :-)
Comment 5 Tomas Zezula 2005-03-21 16:44:06 UTC
Checking in SourcePathImplementation.java;
/cvs/java/j2seproject/src/org/netbeans/modules/java/j2seproject/classpath/SourcePathImplementation.java,v
 <--  SourcePathImplementation.java
new revision: 1.2; previous revision: 1.1
done
Comment 6 Pavel Flaska 2005-09-14 13:30:31 UTC
*** Issue 56200 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo