Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 55627 - Double clicking the project template should move to next step
Double clicking the project template should move to next step
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
4.x
All All
: P1 (vote)
: 7.0.1
Assigned To: Stanislav Aubrecht
issues@platform
: API, UI
: 7336 41091 55879 72752 74774 108157 131566 135105 197452 (view as bug list)
Depends on: 197697
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 17:09 UTC by jrojcek
Modified: 2011-05-02 12:41 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jrojcek 2005-02-28 17:09:19 UTC
If the user double clicks the project/file template in the New 
Project/File wizard, the wizard should move to next step.

Not sure what is the right category, please reassign.

Copied from issue #46060.
Comment 1 Jiri Rechtacek 2005-03-02 17:33:03 UTC
Unluckily, there is no way how to get in WizardDescriptor. The move in
wizard is initialized by a button click :-(
I have no access to these buttons to emulate some click event.
Needs to change WizardDescriptor.
IMHO I close as WONTFIX. If I'm wrong, please reopen if it's a "should
have" feature. Thanks
Comment 2 Milan Kubec 2005-03-03 08:51:10 UTC
I think this is definitely should have feature and if there is
implementation problem on your side it should be reassigned to authors
of WizardDescriptor to provide the functionality. 

IMO such behavior should be supported in all wizards where user
selects some single item and then he's supposed to click Next.

Might be also changed to high prio enhancement.
Comment 3 Jiri Rechtacek 2005-03-03 09:02:19 UTC
Ok, I'll fire a task to WD. Needs API change, probably will be fixed
in next release.
Comment 4 Petr Hrebejk 2005-03-03 16:10:29 UTC
*** Issue 55879 has been marked as a duplicate of this issue. ***
Comment 5 Jiri Rechtacek 2005-03-04 09:08:33 UTC
*** Issue 41091 has been marked as a duplicate of this issue. ***
Comment 6 Jiri Rechtacek 2005-04-26 15:19:03 UTC
*** Issue 7336 has been marked as a duplicate of this issue. ***
Comment 7 Jiri Rechtacek 2005-11-18 13:14:57 UTC
Needs add a way how to provoke wizard framework go to next panel if possible.
Comment 8 Jesse Glick 2006-02-17 14:56:07 UTC
*** Issue 72752 has been marked as a duplicate of this issue. ***
Comment 9 Jesse Glick 2006-04-12 16:59:08 UTC
*** Issue 74774 has been marked as a duplicate of this issue. ***
Comment 10 Jiri Rechtacek 2007-01-12 08:56:22 UTC
This RFE is not in current plans for NB6.0 => target set to Future. If someone
is standing to be implemented in NB6.0, then should escalate it sooner the better.
Comment 11 Jiri Rechtacek 2007-06-27 09:16:16 UTC
*** Issue 108157 has been marked as a duplicate of this issue. ***
Comment 12 Jesse Glick 2008-04-08 18:00:16 UTC
More likely to be searched for in the projects category, though the impl might technically be in openide.loaders.
Comment 13 Milan Kubec 2008-06-20 07:35:08 UTC
*** Issue 135105 has been marked as a duplicate of this issue. ***
Comment 14 Jiri Rechtacek 2011-04-07 08:22:57 UTC
*** Bug 197452 has been marked as a duplicate of this bug. ***
Comment 15 Stanislav Aubrecht 2011-04-21 09:29:12 UTC
core-main 98a33d005d8d
Comment 16 Quality Engineering 2011-04-22 05:07:32 UTC
Integrated into 'main-golden', will be available in build *201104220000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/98a33d005d8d
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #55627 - Double clicking the project template should move to next step
Comment 17 Vladimir Riha 2011-04-22 09:46:37 UTC
Thanks for that. Verified...
Comment 18 Jesse Glick 2011-05-02 12:41:08 UTC
*** Bug 131566 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo