Bug 55485 - Allow filtering treetable results
Allow filtering treetable results
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
4.x
PC All
: P3 (vote)
: 7.2
Assigned To: Jiri Sedlacek
issues@profiler
: VISUALVM
: 117273 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-24 13:47 UTC by iformanek
Modified: 2012-09-27 15:05 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description iformanek 2005-02-24 13:47:55 UTC
The results filtering can be useful in CCT as 
well (and other profilers provide this 
functionality).
The options are:
- not display tree branches that do not have 
anything in them that is filtered
- display the branches that are filtered out as a 
single subnode, collapsing all the filtered out 
nodes into one (without subnodes))
- only indicate that the branch is filtered out 
by grayed icon
Comment 1 iformanek 2005-03-29 15:19:57 UTC
We should probably do at least part of this in 1.0
Comment 2 iformanek 2005-06-20 10:50:40 UTC
Planned for M8
Comment 3 iformanek 2005-07-17 11:52:25 UTC
We will not do this for 1.0
There are several questions to which the answer is not too clear:
- if we filter the tree, so that it only contains paths from roos to all nodes 
matching the filter, is it going to be useful in determining what the call tree 
*under* the matching nodes is - this will ot be displayed, or displayed only 
partially if some other matching node in the the subtree?
- if we filter the tree so that it contais only paths from roots to matching 
nodes, and under them everything, isn't this going to be confusing?
- if we do this second approach (filter until matching nodes, then all), we 
should probably have a feature that "expands all until matching node", or 
something like this to enhance the navigation/visualization by allowing to 
determine the matching nodes

All in all, doing this right may be quite a bit of work - we should implement 
the Find funtionality in 1.0 - Issue 55489 - and do more thorough analysis of 
what the filtering means for the CCT.
Comment 4 iformanek 2005-09-19 11:26:28 UTC
Not for 1.0
Comment 5 Jiri Sedlacek 2007-10-01 10:43:20 UTC
Making this RFE more general - filtering should be possible in all profiler treetables.
Comment 6 Jiri Sedlacek 2007-10-01 10:44:35 UTC
*** Issue 117273 has been marked as a duplicate of this issue. ***
Comment 7 Tomas Hurka 2009-04-08 12:51:25 UTC
Milestone cleanup: future->next
Comment 8 Jiri Sedlacek 2011-11-28 14:11:41 UTC
Implemeted by http://hg.netbeans.org/profiler-main/rev/0ba6412dadf9.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo