Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 55089 - Clean and Build Project fails if Compiling Sources contains another project requiring other compiling source jar files
Clean and Build Project fails if Compiling Sources contains another project r...
Status: RESOLVED DUPLICATE of bug 47507
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
4.x
PC Windows ME/2000
: P3 (vote)
: 4.x
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-16 19:05 UTC by joshunger
Modified: 2005-04-05 00:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description joshunger 2005-02-16 19:05:11 UTC
Clean and Build Project fails if Compiling 
Sources contains another project requiring other 
compiling source jar file if these jar files are 
not listed in this first project.

For example, create Project X and Project Y.  Add 
ajar.jar file under Compiling Sources for Project 
Y.  Next, add Project Y as a Compiling Source 
under Project X.  Now try to Clean and Build 
Project X.  In turn, Project Y is rebuilt but the 
final Project X will fail with class not found 
errors.

The Clean and Build Project option should 
automatically concatenate the classpaths of any 
projects listed in Compiling Sources and use this 
classpath to build the final project jar.

let me know if you need more information...  
thanks.
Comment 1 Tomas Zezula 2005-02-17 09:37:25 UTC
This is a duplicate of already reported issue, but I am not able to
find it either on java or on projects.
Comment 2 Jesse Glick 2005-04-05 00:44:33 UTC
I think the reporter is referring to issue #47507, though it is hard to tell
since the terminology in this issue is quite confused.

*** This issue has been marked as a duplicate of 47507 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo