Bug 55059 - Deadlock when build J2EE application
Deadlock when build J2EE application
Status: RESOLVED WORKSFORME
Product: projects
Classification: Unclassified
Component: Ant
4.x
PC Linux
: P3 (vote)
: 4.x
Assigned To: Jesse Glick
issues@projects
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-16 15:24 UTC by Petr Blaha
Modified: 2005-03-10 16:21 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (12.89 KB, text/plain)
2005-02-16 15:24 UTC, Petr Blaha
Details
project (133.45 KB, application/octet-stream)
2005-02-23 11:10 UTC, Petr Blaha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Blaha 2005-02-16 15:24:12 UTC
[Build 20050215]
I get deadlock when build J2EE application. I
can't reproduce all steps. I worked half day with
IDE. thread dump attached.
Comment 1 Petr Blaha 2005-02-16 15:24:53 UTC
Created attachment 20378 [details]
thread dump
Comment 2 Vince Kraemer 2005-02-22 18:04:33 UTC
I guess I need more info on this one.

Had you run the j2ee project successfully "earlier"?

Do you still have the project?
Comment 3 Petr Blaha 2005-02-23 11:09:24 UTC
I preformed following steps several times: deploy, run, debugg J2EE
application. I'm sorry, I attached application.
Comment 4 Petr Blaha 2005-02-23 11:10:00 UTC
Created attachment 20471 [details]
project
Comment 5 Vince Kraemer 2005-02-24 08:02:11 UTC
The most active (depth-wise) thread is doing ant "stuff".

I don't see j2ee in the stack anywhere.

Reassigning to see if the stack rings any bells with the ant team.
Comment 6 Jesse Glick 2005-03-10 16:21:11 UTC
Don't know; don't see anything especially wrong with the thread dump, but it is
not especially informative either. EQ is marked as being "runnable". No info on
what "condition" the Ant thread is waiting on. Not clear if this is really a
deadlock, or a livelock. Sorry; if you can reproduce somehow, could at least
send to JVM engineers for analysis.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo