Bug 55043 - Focus Based Window History
Focus Based Window History
Status: RESOLVED DUPLICATE of bug 44144
Product: platform
Classification: Unclassified
Component: Window System
4.x
All All
: P2 (vote)
: 6.x
Assigned To: jrojcek
issues@platform
: FOCUS, UI, USABILITY
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-16 12:07 UTC by _ pkuzel
Modified: 2008-12-22 18:24 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ pkuzel 2005-02-16 12:07:52 UTC
I have multiple opened sources. On current one I
invoke Diff action mapped to Ctrl-Shft_D hotkey.
Diff is OK. So I close it using Ctrl_F4. Then I
press Ctrl-Shft_K for commit.  BUT I have commited
different file!

Expected behaviour is that after closing a editor
area window focus moves to previously focused
editor area window (focus based history). 

The current behaviour is that focus movement it
driven by window opening sequence.
Comment 1 _ pkuzel 2005-02-16 12:12:45 UTC
Alternatively mark as P2 ENHANCEMENT to be addressed in future.
Comment 2 Milos Kleint 2005-03-15 13:26:40 UTC
I believe focus based history can be unintuitive and chaotic. having keyboard
shortcuts to iterate back and forth in focus based history is ok. The usecase
with closing an window sounds strange. I would like to have feedback from HIE if
we want to do this or not. Definitely not a bug though.
Comment 3 Martin Krauskopf 2005-03-16 14:57:16 UTC
I think too that this should be implemented. I'm used to it e.g. from VIM. Emacs
and other IDEs use a focus based history as well. But some users probably prefer
current behaviour (e.g. Firefox behaves as NetBeans now). So reassigning to HIE
for consideration. Please reassign back to me then. Thanks.
Changing to supposed P2 enhancement since as Milos said it is really not a bug.
Comment 4 Marian Mirilovic 2006-08-17 07:56:48 UTC

*** This issue has been marked as a duplicate of 44144 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo