Bug 55005 - Save changed html/jsp file freezes whole IDE for a while
Save changed html/jsp file freezes whole IDE for a while
Status: CLOSED FIXED
Product: web
Classification: Unclassified
Component: HTML Editor
4.x
PC Linux
: P1 (vote)
: 4.x
Assigned To: Marek Fukala
Jindrich Sedek
perfuiresp 4.1_beta_fix
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-16 06:29 UTC by Marian Mirilovic
Modified: 2009-05-18 10:45 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread-dump during freeze (7.70 KB, text/plain)
2005-02-16 06:29 UTC, Marian Mirilovic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2005-02-16 06:29:16 UTC
NB4.1 (200502151900), JDK1.5.0_03 (ea)

Steps to reproduce:
- run IDE
- open html file (I've opened 40kB file with big
table)
- change anything and press Ctrl+S (Save)
-> whole IDE freezes for a while (see attached
thread-dump)
Comment 1 Marian Mirilovic 2005-02-16 06:29:43 UTC
Created attachment 20358 [details]
thread-dump during freeze
Comment 2 Marian Mirilovic 2005-02-16 06:32:21 UTC
Every time I write something to editor it slows down and slept for at
least 2-3 seconds, it's hard to write anything to HTML file ....

Comment 3 _ rkubacki 2005-02-16 08:28:32 UTC
It seems that fold processing in AWT dispatch thread is not a good idea.
Comment 4 Marek Fukala 2005-02-16 12:20:04 UTC
Radime, you are right. It is bad idea and I will change it.

Mariane, the fold update code being run in awt thread is one problem.
Another issue is that making folds for 40kB file should not take 2-3
seconds. Can you please attach the file? Or does this problem happen
for every html file?
Comment 5 Marek Fukala 2005-02-16 13:08:02 UTC
the some problem wiht folds update code run in event dispatch thread
applies for jsp files.
Comment 6 Marek Fukala 2005-02-16 13:09:04 UTC
fixed for JSP files

Checking in JspFoldManager.java;
/cvs/web/jspsyntax/src/org/netbeans/modules/web/core/syntax/folding/JspFoldManager.java,v
 <--  JspFoldManager.java
new revision: 1.15; previous revision: 1.14
done
Comment 7 Antonin Nebuzelsky 2005-02-16 13:42:50 UTC
This is IMHO q-build and beta stopper. Fixes should be integrated in
the branches as well I believe.
Comment 8 Marek Fukala 2005-02-16 16:14:29 UTC
Fixed for HTML files. Folds update code now runs in a background
thread. The slowness of the folds code itself is another issue and
should be filled separatelly.

I will wait for QE's opinion and if it is OK i will integrate the fix
into q-build branch as well.

Checking in HTMLFoldManager.java;
/cvs/html/editor/src/org/netbeans/modules/html/editor/folding/HTMLFoldManager.java,v
 <--  HTMLFoldManager.java
new revision: 1.7; previous revision: 1.6
done
Comment 9 Antonin Nebuzelsky 2005-02-16 16:31:54 UTC
Please, don't close before fixed in beta branch.
Comment 10 Marek Fukala 2005-02-16 16:38:52 UTC
fixed properly for JSPs as well.

Sory for the hasty closing, I was very happy it works now so I forgot
the rule ;-).

Checking in JspFoldManager.java;
/cvs/web/jspsyntax/src/org/netbeans/modules/web/core/syntax/folding/JspFoldManager.java,v
 <--  JspFoldManager.java
new revision: 1.16; previous revision: 1.15
done
Comment 11 Jiri Kovalsky 2005-02-17 09:38:38 UTC
I am working on verification of this defect. The problem is that
current continuous build (#20050217-0738) contains issue #55115 which
results in bunch of IAE exceptions and I have no idea if it can
potentially influence behaviour described in this issue.
Comment 12 Jiri Kovalsky 2005-02-17 13:37:26 UTC
I have tried to reproduce the problem or find some regression in HTML,
JSP and TagLib editors but without success. Thus I agree with the fix.
Please commit it into both Q-build and Beta branches.
Comment 13 Marek Fukala 2005-02-17 14:17:53 UTC
fixed in QBE200502151900

Checking in JspFoldManager.java;
/cvs/web/jspsyntax/src/org/netbeans/modules/web/core/syntax/folding/JspFoldManager.java,v
 <--  JspFoldManager.java
new revision: 1.14.4.1; previous revision: 1.14
done
Checking in HTMLFoldManager.java;
/cvs/html/editor/src/org/netbeans/modules/html/editor/folding/HTMLFoldManager.java,v
 <--  HTMLFoldManager.java
new revision: 1.6.4.1; previous revision: 1.6
done


fixed in release41_beta

Checking in JspFoldManager.java;
/cvs/web/jspsyntax/src/org/netbeans/modules/web/core/syntax/folding/JspFoldManager.java,v
 <--  JspFoldManager.java
new revision: 1.14.2.1; previous revision: 1.14
done
Checking in HTMLFoldManager.java;
/cvs/html/editor/src/org/netbeans/modules/html/editor/folding/HTMLFoldManager.java,v
 <--  HTMLFoldManager.java
new revision: 1.6.2.1; previous revision: 1.6
done
Comment 14 Marian Mirilovic 2005-03-07 06:50:22 UTC
verified in NB4.1 (200503061900)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo