Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 54905 - WizardDescriptor's Properties are not developer-friendly
WizardDescriptor's Properties are not developer-friendly
Status: RESOLVED DUPLICATE of bug 138128
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
4.x
All All
: P1 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
:
Depends on: 26552
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-12 14:48 UTC by santhosh
Modified: 2008-12-22 10:54 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description santhosh 2005-02-12 14:48:16 UTC
WizardDescriptor supports various properties such as 
PROP_AUTO_WIZARD_STYLE, PROP_HELP_DISPLAYED etc.

these constants are private variables.

it is very pain to refer to the documentation
every time, and add //NOI18N in my code.

plz expose these variables and/or provide methods like
  public void setAutoWizardStype(boolean)
  public void setImage(Image)
  public void setLeftDimention(Dimention)

I suggest providing such methods as developers
don't need to remember the value type of a property.

currenty I MyWizardDescriptor which extends 
WizardDiscriptor and added such methods. Now
I use MyWizardDescriptor at all places instead 
of WizardDescriptor. this made my life easier.

It takes just 5 minutes to fix this.
Comment 1 Jiri Rechtacek 2005-02-14 09:09:18 UTC
Yes, it should be better. There is issue 26552 improve the WD API and
rid of client-properties, it's being developed in branch wizards_26552
but not in progress for in promoE.
Comment 2 Martin Krauskopf 2006-08-02 22:29:25 UTC
As more people starting to build applications on top of NB platform a lot of
people are asking similar question on mailing list. I think that at least
getting rid of those "strings" is P1 and should be done for next release. (in
the case that the whole API is not planned ;)
Comment 3 Milan Kubec 2008-06-30 13:45:46 UTC

*** This issue has been marked as a duplicate of 138128 ***
Comment 4 Martin Krauskopf 2008-06-30 13:53:53 UTC
54905 < 138128


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo