Bug 54835 - [ejb] Unable to build EJB module with ws client
[ejb] Unable to build EJB module with ws client
Status: CLOSED FIXED
Product: webservices
Classification: Unclassified
Component: Code
4.x
PC All
: P1 (vote)
: 4.x
Assigned To: _ pcw
issues@webservices
:
Depends on: 53391
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-10 14:52 UTC by Lukas Jungmann
Modified: 2006-03-24 12:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Jungmann 2005-02-10 14:52:36 UTC
[build 200502091900]

1. create new EJB module
2. create JAXRPC ws client in for some running ws
3. create simple session bean
4. build project

=> see output window:

"Circular dependency: pre-compile <- do-compile <-
wscompile-init <- GoogleSearch_client_wscompile <-
pre-compile
BUILD FAILED (total time: 0 seconds)"
Comment 1 _ pcw 2005-02-12 01:07:35 UTC
This bug was caused by part of the fix to bug #53391 which made
wscompile depend on <do-compile>.  Since web service clients are
always done in the pre-compile phase so that the result is available
when javac is run on the user's source, this produces a circular
dependency.

The fix here is to revert this change and fix #53391 correctly.
Comment 2 Marek Fukala 2005-02-16 18:47:23 UTC
fixed in trunk. The wscompile-init now depends on init. Sorry for the
troubles, I do not understand how I could create such a stupid
dependency ;-)

Thanks jungi for exploring this!

I will commit the fix into qbuild branch after QE checks it.

Checking in build-impl.xsl;
/cvs/j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.28; previous revision: 1.27
done
Comment 3 Lukas Jungmann 2005-02-17 12:15:53 UTC
It seems that Marek's fix also fixes this issue.

Now waiting for commit to qbuild and beta branch.
Comment 4 Marek Fukala 2005-02-17 13:48:34 UTC
fixed in QBE200502151900

Checking in build-impl.xsl;
/cvs/j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.27.4.1; previous revision: 1.27
done

fixed in release41_beta

Checking in build-impl.xsl;
/cvs/j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.27.2.1; previous revision: 1.27
done
Comment 5 Lukas Jungmann 2005-03-02 13:33:50 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo