Bug 53468 - Hang with shared drives
Hang with shared drives
Status: CLOSED DUPLICATE of bug 46813
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
4.x
PC Windows XP
: P1 (vote)
: 4.x
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-15 22:18 UTC by schwarcz
Modified: 2006-03-24 10:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description schwarcz 2005-01-15 22:18:20 UTC
I've got an NB 4.0 project on my Win XP Pro JDK
5.0 desktop and would like to edit it (sources,
ant script, and some resources) on another Win XP
Pro JDK 5.0 machine on the LAN (my laptop).  Can
anybody suggest the correct way to do this?

On the laptop if I try to open the existing
project on the shared network drive (e.g.
\\Carl2\d) the NB file dialog show no contents (no
directories or file) on the drive.  I suspect this
is a limitation of J2SE 5.0.

If I map the project parent directory (containing
source, resources, and the NB project directory)
to a drive letter, then I can see the files but it
complains that it cannot resolve the references to
the source directories.  If I try to resolve the
references, NB hangs hard using no cpu cycles. 
The resolve Reference Problems window does not get
repainted.  The only way to proceed is to kill the
process.
Comment 1 Jesse Glick 2005-01-16 17:12:05 UTC
UNC paths do not work yet; will fix later. See issue #46813 for
details. In the meantime you should be able to use mapped drive letters.

Re. resolving references to source directories: if the source
directories were using relative paths to begin with, there would be no
need to do so, but this will be necessary in case you were using
external source directories, as the paths might be different on the
new machine.

Re. hang: never heard of such a hang, but if you can reproduce, please
reopen and attach (1) your messages.log file for background
information, (2) a thread dump of the hung IDE, obtainable using
nb.exe (not netbeans.exe) and pressing Ctrl-Break in the console
window and then copy-pasting into a text file. If we can see the
thread dump, we might be able to fix the problem and/or suggest a
workaround.

*** This issue has been marked as a duplicate of 46813 ***
Comment 2 Marian Mirilovic 2006-01-10 12:41:07 UTC
verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo