Bug 53391 - Unable to compile web service when included in J2EE application
Unable to compile web service when included in J2EE application
Status: CLOSED FIXED
Product: webservices
Classification: Unclassified
Component: Code
4.x
PC All
: P1 (vote)
: 4.x
Assigned To: Marek Fukala
issues@webservices
:
Depends on:
Blocks: 54835
  Show dependency treegraph
 
Reported: 2005-01-14 00:34 UTC by Chris Webster
Modified: 2006-03-24 13:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Webster 2005-01-14 00:34:21 UTC
The following exception is generated when
compiling web service included in J2EE application:

RmiModeler error:
java.lang.ClassNotFoundException:
com$acme$conversational$gen$ws$ConversationalWebServiceSEI
    at
com.sun.xml.rpc.processor.modeler.rmi.RmiModeler.modelPort(RmiModeler.java:685)
    at
com.sun.xml.rpc.processor.modeler.rmi.RmiModeler.buildEncodedModel(RmiModeler.java:523)
    at
com.sun.xml.rpc.processor.modeler.rmi.RmiModeler.buildModel(RmiModeler.java:459)
    at
com.sun.xml.rpc.processor.config.ModelInfo.buildModel(ModelInfo.java:88)
    at
com.sun.xml.rpc.processor.Processor.runModeler(Processor.java:63)
    at
com.sun.xml.rpc.tools.wscompile.CompileTool.run(CompileTool.java:714)
    at
com.sun.xml.rpc.util.ToolBase.run(ToolBase.java:43)
    at
com.sun.xml.rpc.tools.wscompile.Main.main(Main.java:22)

CAUSE:

java.lang.ClassNotFoundException:
com$acme$conversational$gen$ws$ConversationalWebServiceSEI
    at
java.net.URLClassLoader$1.run(URLClassLoader.java:200)
    at
java.security.AccessController.doPrivileged(Native
Method)
    at
java.net.URLClassLoader.findClass(URLClassLoader.java:188)
    at
java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at
java.lang.ClassLoader.loadClass(ClassLoader.java:251)
    at
java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:242)
    at
com.sun.xml.rpc.processor.modeler.rmi.RmiUtils.getLoadableClassName(RmiUtils.java:78)
    at
com.sun.xml.rpc.processor.modeler.rmi.RmiUtils.getLoadableClassName(RmiUtils.java:84)
    at
com.sun.xml.rpc.processor.modeler.rmi.RmiUtils.getLoadableClassName(RmiUtils.java:84)
    at
com.sun.xml.rpc.processor.modeler.rmi.RmiUtils.getLoadableClassName(RmiUtils.java:84)
    at
com.sun.xml.rpc.processor.modeler.rmi.RmiUtils.getLoadableClassName(RmiUtils.java:84)
    at
com.sun.xml.rpc.processor.modeler.rmi.RmiUtils.getLoadableClassName(RmiUtils.java:84)
    at
com.sun.xml.rpc.processor.modeler.rmi.RmiUtils.getRealName(RmiUtils.java:54)
    at
com.sun.xml.rpc.processor.modeler.rmi.RmiModeler.modelPort(RmiModeler.java:676)
    at
com.sun.xml.rpc.processor.modeler.rmi.RmiModeler.buildEncodedModel(RmiModeler.java:523)
    at
com.sun.xml.rpc.processor.modeler.rmi.RmiModeler.buildModel(RmiModeler.java:459)
    at
com.sun.xml.rpc.processor.config.ModelInfo.buildModel(ModelInfo.java:88)
    at
com.sun.xml.rpc.processor.Processor.runModeler(Processor.java:63)
    at
com.sun.xml.rpc.tools.wscompile.CompileTool.run(CompileTool.java:714)
    at
com.sun.xml.rpc.util.ToolBase.run(ToolBase.java:43)
    at
com.sun.xml.rpc.tools.wscompile.Main.main(Main.java:22)
error: RmiModeler error:
java.lang.ClassNotFoundException:
com$acme$conversational$gen$ws$ConversationalWebServiceSEI
Comment 1 L Martinek 2005-01-21 13:44:17 UTC
I think it's more serious. Upgrading to P1.
Comment 2 L Martinek 2005-01-21 14:02:27 UTC
When I build EJB module and Web application at first then building of
whole Enterprise Application passes. When I select Clean & Build on
Enterprise Application it fails.
Comment 3 L Martinek 2005-01-21 16:01:11 UTC
It's probably related to this bug too: When I tried to deploy such
enterprise application, I got error that ear is not valid J2EE
archive. When I looked at it I found out that web.xml is missing
inside war.
Comment 4 Marek Fukala 2005-01-24 16:57:24 UTC
I looks like the problem is caused by my ear libraries packaging
changes. I will try to fix it even I am not so much familiar witg web
services.
Comment 5 Marek Fukala 2005-01-25 15:09:38 UTC
fixed 

Checking in build-impl.xsl;
/cvs/web/project/src/org/netbeans/modules/web/project/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.66; previous revision: 1.65
done
Comment 6 Lukas Jungmann 2005-02-02 13:00:15 UTC
i'm able to reproduce this in build 200502012121.
Comment 7 Marek Fukala 2005-02-03 14:33:13 UTC
I fixed the problem in web appplication. Now it fails when there is a
webservice in an ejb project. Please add exact steps to reproduce the
problem next time. It will help me save some time and easy
verification as well.

Thanks.
Comment 8 Marek Fukala 2005-02-03 18:39:57 UTC
I have created a fix and jungi is going to verify it tomorrow. If the
fix is ok, I will integrate it.
Comment 9 Marek Fukala 2005-02-04 10:32:08 UTC
fixed in trunk

Checking in
src/org/netbeans/modules/j2ee/ejbjarproject/resources/build-impl.xsl;
/cvs/j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/resources/build-impl.xsl,v
 <--
 build-impl.xsl
new revision: 1.25; previous revision: 1.24
done
Comment 10 Marek Fukala 2005-02-04 10:43:31 UTC
fixed in QBE200502012121 branch as well.
Comment 11 Lukas Jungmann 2005-02-07 13:34:10 UTC
v. 200502061900
Comment 12 _ pcw 2005-02-12 01:05:10 UTC
I'm reopening this issue because part of the fix (revision 1.25 of
build-impl.xsl for ejbjarproject) caused bug #54835.

<wscompile-init> was changed to depend on <do-compile>.  This cannot
be done ever because this task is a shared dependency with tasks that
are done during the <pre-compile> phase (hence the new circular
dependency bug referenced above.)

<wscompile-init> is an init task and should not need to depend on
anything (except maybe <init> itself, but it has not been necessary to
make that explicit.)  I do not understand why it was deemed necessary
change it to fix this bug, but if someone can explain it to me, I
would be happy to help devise a better solution.
Comment 13 Marek Fukala 2005-02-16 18:47:53 UTC
fixed in trunk. The wscompile-init now depends on init. Sorry for the
troubles, I do not understand how I could create such a stupid
dependency ;-)

Thanks jungi for exploring this!

I will commit the fix into qbuild branch after QE checks it.

Checking in build-impl.xsl;
/cvs/j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.28; previous revision: 1.27
done
Comment 14 Lukas Jungmann 2005-02-17 10:54:40 UTC
checked in build 200502170805,

marku, can you commit it to qbuild branch?

Thanks.
Comment 15 Lukas Jungmann 2005-02-17 12:11:29 UTC
and to beta branch too, please
Comment 16 Marek Fukala 2005-02-17 13:47:35 UTC
fixed in QBE200502151900

Checking in build-impl.xsl;
/cvs/j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.27.4.1; previous revision: 1.27
done

fixed in release41_beta

Checking in build-impl.xsl;
/cvs/j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.27.2.1; previous revision: 1.27
done

Comment 17 L Martinek 2005-04-13 12:46:28 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo