Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 53147 - Automatically update javadoc on Change Method Parameters > Do Refactoing
Automatically update javadoc on Change Method Parameters > Do Refactoing
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Refactoring
4.x
PC Windows ME/2000
: P2 with 1 vote (vote)
: 7.1
Assigned To: Ralph Ruijs
issues@java
:
: 128036 (view as bug list)
Depends on:
Blocks: 65780
  Show dependency treegraph
 
Reported: 2005-01-09 21:20 UTC by Charlie Hunt
Modified: 2014-06-24 09:16 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Charlie Hunt 2005-01-09 21:20:38 UTC
When doing a Refactor > Change Method Parameters >
Do Refactoring, the IDE should also update the
javadoc automatically. It should also have a
checkbox in the output window identifying that it
will udpate the javadoc for the method having a
change in method parameters. In addition, if you
undo the Refactoring, it should also undo the
javadoc update.

Currently, the javadoc for a refactoring using
Change Method Parameters does not change the
affected method's javadoc automatically. You have
to do it in a separate command or do it manually.
Comment 1 Ralph Ruijs 2011-06-08 10:59:07 UTC
Changeset: d9a8f1cf9a25
Author:    Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
Date:      2011-06-08 12:50
Message:   
Issue #53147 - Automatically update javadoc on Change Method Parameters > Do Refactoing
Comment 2 Quality Engineering 2011-06-10 14:47:37 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/d9a8f1cf9a25
User: Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
Log: Issue #53147 - Automatically update javadoc on Change Method Parameters > Do Refactoing
Comment 3 Ralph Ruijs 2011-10-17 13:52:26 UTC
*** Bug 128036 has been marked as a duplicate of this bug. ***
Comment 4 bazi 2014-06-24 09:14:46 UTC
Changing return type of a method from void to some type in "Change Method Parameters" refactoring window does not update javadoc, i.e. @return is not added into javadoc.
Comment 5 Ralph Ruijs 2014-06-24 09:16:57 UTC
(In reply to bazi from comment #4)
> Changing return type of a method from void to some type in "Change Method
> Parameters" refactoring window does not update javadoc, i.e. @return is not
> added into javadoc.

Please create a new issue if this enhancement is not working properly. Thanks!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo