Bug 52660 - Exception while creating ws-client from URL of running service
Exception while creating ws-client from URL of running service
Status: CLOSED FIXED
Product: webservices
Classification: Unclassified
Component: Code
4.x
PC Linux
: P1 (vote)
: TBD
Assigned To: _ pcw
issues@webservices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-20 10:45 UTC by Lukas Jungmann
Modified: 2006-03-24 12:58 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (58.88 KB, text/plain)
2004-12-20 10:46 UTC, Lukas Jungmann
Details
messages.log (207.08 KB, text/plain)
2004-12-22 16:33 UTC, Lukas Jungmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Jungmann 2004-12-20 10:45:37 UTC
[build: 20041220-0843]

Create new webservice client with following
settings in the wizard:

- enter URL of running service in the field for it
and press Retrieve WSDL
- set package name for generated interfaces to eg.
client
- set ws client type to JSR-109 (for JAXRPC static
stub the exception is the same)
- press Finish

=> java.lang.reflect.UndeclaredThrowableException

- press Finish again

=> client is created successfully
Comment 1 Lukas Jungmann 2004-12-20 10:46:41 UTC
Created attachment 19360 [details]
messages.log
Comment 2 Lukas Jungmann 2004-12-22 16:32:50 UTC
[build: 200412212112]

i'm getting exceptions everytime i press finish in the wizard => i
can't create ws client.

Increasing priority to P1 because this is one of the features in NB 4.1.
Comment 3 Lukas Jungmann 2004-12-22 16:33:54 UTC
Created attachment 19399 [details]
messages.log
Comment 4 _ pcw 2004-12-22 21:08:55 UTC
The UndeclaredThrowableException is really a wrapper on a
ConcurrentModificationException that I think I've identified and
fixed.  (I couldn't reproduce it, but from code inspection I did
identify what could have caused this and it's fixed.)

The exception at the end of the second attachment is an unrelated
trivial error that has also been fixed.
Comment 5 _ pcw 2004-12-22 22:35:14 UTC
see above comment :)
Comment 6 Lukas Jungmann 2005-01-04 10:44:59 UTC
verified in 200501031900


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo