Bug 52629 - Deploy command needs to do some validation first
Deploy command needs to do some validation first
Status: RESOLVED DUPLICATE of bug 49490
Product: javaee
Classification: Unclassified
Component: EAR
4.x
PC Windows ME/2000
: P3 (vote)
: 4.x
Assigned To: Vince Kraemer
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-17 18:50 UTC by Vince Kraemer
Modified: 2006-06-03 17:50 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vince Kraemer 2004-12-17 18:50:51 UTC
This is easy to see with the Populated Enterprise
Application or the EJB Module project.

Steps:

1. create one of these projects.
2. deploy.  The deploy will fail.

The app is not initially deployable.  The error is
not detected until the app is handed to the server.
Comment 1 Vince Kraemer 2005-02-07 18:40:47 UTC
The root cause of this is the same as the root cause of 49490:

The DD is not valid [in this case there isn't an ejb "subelement" of
the  enterprise-beans element of the dtd/schema.

validating the XML earlier in the build process would catch this issue.

*** This issue has been marked as a duplicate of 49490 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo