Bug 5255 - On open Find Dialog, IDE freeze
On open Find Dialog, IDE freeze
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
Sun Solaris
: P1 (vote)
: TBD
Assigned To: David Kaspar
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-10 02:16 UTC by David Kaspar
Modified: 2008-12-23 10:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Kaspar 2000-01-10 02:16:52 UTC
{JDK 1.2.1}

When I try to open Find Dialog in Editor using Ctrl+F, it will be open empty and IDE freeze.

[Svata, Windows NT]: Find dialog works, except that pressing cancel saves current settings in the dialog.

Replace may freeze IDE (see bug #4228). Steps to reproduce:
- Open Replace dialog, uncheck both highlight search and incremenetal search press `Replace All`
- If the IDE does not freeze, repeat the operation.

`Replace All` that would replace text in a guarded block freezes IDE (regardless of highlight/incremental options): Open Development/examples/advanced/MemoryView and replace `initComponents` with anyt
hing

Replace All dialog remembers dialog settings even if user cancels the operation.

[Mila]
Please provide a thread dump for the first problem. Please don`t enter two differnet problems into one change request.
Comment 1 Quality Engineering 2003-07-02 16:17:55 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo