Bug 52176 - I18N - the Open File dialog does not show Chinese characters
I18N - the Open File dialog does not show Chinese characters
Status: RESOLVED DUPLICATE of bug 50993
Product: utilities
Classification: Unclassified
Component: Open File
4.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: issues@utilities
issues@utilities
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-08 02:13 UTC by yenfuli
Modified: 2005-01-21 12:21 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
the fail and ok open file dialog (86.90 KB, image/gif)
2004-12-08 02:22 UTC, yenfuli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yenfuli 2004-12-08 02:13:03 UTC
1.the file open dialog  show chiness-big5 fail 
2. if i change the fontsize of ide --fontsize 12
   then it's work.
Comment 1 yenfuli 2004-12-08 02:22:38 UTC
Created attachment 19195 [details]
the fail and ok open file dialog
Comment 2 Milan Kubec 2004-12-13 08:36:08 UTC
Reassigning to i18n for evaluation.
Comment 3 Marian Petras 2004-12-13 09:54:34 UTC
This is not a bug in NetBeans. The problem is that either some Chinese
fonts are missing on the computer or the JVM (Java Virtual Machine) is
not properly configured to use them.

Document "Java Internatinalization FAQ"
(http://java.sun.com/j2se/corejava/intl/reference/faqs/index.html)
should contain useful information on how to solve such problems. The
document also refers other documents - one for JDK 1.4.x
(http://java.sun.com/j2se/1.4.2/docs/guide/intl/font.html) and another
for JDK 1.5.x
(http://java.sun.com/j2se/1.5.0/docs/guide/intl/fontconfig.html).

Terms "logical fonts" and "physical fonts" are used in the above
documents. For your information, NetBeans uses "logical fonts".

Since the problem is not caused by the NetBeans bug, I am marking it
as INVALID.
Comment 4 Marian Petras 2004-12-13 09:56:08 UTC
One more document that could help you is located at

   http://www.scheduleworld.com/i18n.html
Comment 5 Marian Petras 2005-01-21 12:15:31 UTC
Reopening so that it can be re-classified.
Comment 6 Marian Petras 2005-01-21 12:21:54 UTC
This is an exact duplicate of bug #50993 ("Cannot display Chinese text
in FileChooser").

It appeared to be actually a bug in JDK (i.e. not in the client's
setup). The bug is reported to be fixed in JDK 5.0 update 1 but the
reporter claims that he encountered the same bug with the updater
release, too. See bug #50993 for more details.

*** This issue has been marked as a duplicate of 50993 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo