Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 51602 - InvocationTargetException thrown while creating project
InvocationTargetException thrown while creating project
Status: CLOSED INVALID
Product: projects
Classification: Unclassified
Component: Ant
4.x
PC Windows XP
: P3 (vote)
: 4.x
Assigned To: Pavel Buzek
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 14:37 UTC by bknights
Modified: 2006-03-24 09:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
NetBeans log file (90.61 KB, text/plain)
2004-11-17 14:39 UTC, bknights
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bknights 2004-11-17 14:37:46 UTC
I was creating a project from an ant script after
installing the profiler. 
After opening the ant script and assigning a
target from my build.xml file as the Build Project
action I hit the Next button. 
A dialog titled Unexpected Exception opened. 
The details button had the following stack trace:

java.lang.reflect.UndeclaredThrowableException
	at $Proxy12.actionPerformed(Unknown Source)
	at
javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1786)
	at
javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(AbstractButton.java:1839)
	at
javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
	at
javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
	at
javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:245)
	at
java.awt.Component.processMouseEvent(Component.java:5100)
	at
java.awt.Component.processEvent(Component.java:4897)
	at
java.awt.Container.processEvent(Container.java:1569)
	at
java.awt.Component.dispatchEventImpl(Component.java:3615)
	at
java.awt.Container.dispatchEventImpl(Container.java:1627)
	at
java.awt.Component.dispatchEvent(Component.java:3477)
	at
java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:3483)
	at
java.awt.LightweightDispatcher.processMouseEvent(Container.java:3198)
	at
java.awt.LightweightDispatcher.dispatchEvent(Container.java:3128)
	at
java.awt.Container.dispatchEventImpl(Container.java:1613)
	at
java.awt.Window.dispatchEventImpl(Window.java:1606)
	at
java.awt.Component.dispatchEvent(Component.java:3477)
	at
java.awt.EventQueue.dispatchEvent(EventQueue.java:456)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:141)
	at java.awt.Dialog$1.run(Dialog.java:540)
	at java.awt.Dialog.show(Dialog.java:561)
	at
org.netbeans.core.windows.services.NbPresenter.superShow(NbPresenter.java:780)
	at
org.netbeans.core.windows.services.NbPresenter.doShow(NbPresenter.java:823)
	at
org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:811)
	at org.openide.util.Mutex$1.run(Mutex.java:937)
	at
java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:171)
	at
java.awt.EventQueue.dispatchEvent(EventQueue.java:454)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
	at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
	at
java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
Caused by: java.lang.reflect.InvocationTargetException
	at
sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)
	at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:324)
	at
org.openide.util.WeakListenerImpl$ProxyListener.invoke(WeakListenerImpl.java:383)
	... 35 more
Caused by: java.lang.NullPointerException
	at
org.netbeans.modules.ant.freeform.ui.SourceFoldersPanel.hasSomeSourceFolder(SourceFoldersPanel.java:307)
	at
org.netbeans.modules.ant.freeform.ui.NewWebFreeformProjectWizardIterator.hasNext(NewWebFreeformProjectWizardIterator.java:156)
	at
org.netbeans.modules.ant.freeform.ui.NewWebFreeformProjectWizardIterator.nextPanel(NewWebFreeformProjectWizardIterator.java:166)
	at
org.openide.loaders.TemplateWizard$Brigde2Iterator.nextPanel(TemplateWizard.java:940)
	at
org.openide.loaders.TemplateWizardIterImpl.nextPanel(TemplateWizardIterImpl.java:136)
	at
org.openide.WizardDescriptor$Listener.actionPerformed(WizardDescriptor.java:1271)
[catch] ... 40 more
==>
java.lang.reflect.InvocationTargetException
	at
sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)
	at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:324)
	at
org.openide.util.WeakListenerImpl$ProxyListener.invoke(WeakListenerImpl.java:383)
	at $Proxy12.actionPerformed(Unknown Source)
	at
javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1786)
	at
javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(AbstractButton.java:1839)
	at
javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
	at
javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
	at
javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:245)
	at
java.awt.Component.processMouseEvent(Component.java:5100)
	at
java.awt.Component.processEvent(Component.java:4897)
	at
java.awt.Container.processEvent(Container.java:1569)
	at
java.awt.Component.dispatchEventImpl(Component.java:3615)
	at
java.awt.Container.dispatchEventImpl(Container.java:1627)
	at
java.awt.Component.dispatchEvent(Component.java:3477)
	at
java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:3483)
	at
java.awt.LightweightDispatcher.processMouseEvent(Container.java:3198)
	at
java.awt.LightweightDispatcher.dispatchEvent(Container.java:3128)
	at
java.awt.Container.dispatchEventImpl(Container.java:1613)
	at
java.awt.Window.dispatchEventImpl(Window.java:1606)
	at
java.awt.Component.dispatchEvent(Component.java:3477)
	at
java.awt.EventQueue.dispatchEvent(EventQueue.java:456)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:141)
	at java.awt.Dialog$1.run(Dialog.java:540)
	at java.awt.Dialog.show(Dialog.java:561)
	at
org.netbeans.core.windows.services.NbPresenter.superShow(NbPresenter.java:780)
	at
org.netbeans.core.windows.services.NbPresenter.doShow(NbPresenter.java:823)
	at
org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:811)
	at org.openide.util.Mutex$1.run(Mutex.java:937)
	at
java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:171)
	at
java.awt.EventQueue.dispatchEvent(EventQueue.java:454)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
	at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
	at
java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
Caused by: java.lang.NullPointerException
	at
org.netbeans.modules.ant.freeform.ui.SourceFoldersPanel.hasSomeSourceFolder(SourceFoldersPanel.java:307)
	at
org.netbeans.modules.ant.freeform.ui.NewWebFreeformProjectWizardIterator.hasNext(NewWebFreeformProjectWizardIterator.java:156)
	at
org.netbeans.modules.ant.freeform.ui.NewWebFreeformProjectWizardIterator.nextPanel(NewWebFreeformProjectWizardIterator.java:166)
	at
org.openide.loaders.TemplateWizard$Brigde2Iterator.nextPanel(TemplateWizard.java:940)
	at
org.openide.loaders.TemplateWizardIterImpl.nextPanel(TemplateWizardIterImpl.java:136)
	at
org.openide.WizardDescriptor$Listener.actionPerformed(WizardDescriptor.java:1271)
[catch] ... 40 more
==>
java.lang.NullPointerException
	at
org.netbeans.modules.ant.freeform.ui.SourceFoldersPanel.hasSomeSourceFolder(SourceFoldersPanel.java:307)
	at
org.netbeans.modules.ant.freeform.ui.NewWebFreeformProjectWizardIterator.hasNext(NewWebFreeformProjectWizardIterator.java:156)
	at
org.netbeans.modules.ant.freeform.ui.NewWebFreeformProjectWizardIterator.nextPanel(NewWebFreeformProjectWizardIterator.java:166)
	at
org.openide.loaders.TemplateWizard$Brigde2Iterator.nextPanel(TemplateWizard.java:940)
	at
org.openide.loaders.TemplateWizardIterImpl.nextPanel(TemplateWizardIterImpl.java:136)
	at
org.openide.WizardDescriptor$Listener.actionPerformed(WizardDescriptor.java:1271)
	at
sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)
	at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:324)
	at
org.openide.util.WeakListenerImpl$ProxyListener.invoke(WeakListenerImpl.java:383)
	at $Proxy12.actionPerformed(Unknown Source)
	at
javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1786)
	at
javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(AbstractButton.java:1839)
	at
javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
	at
javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
	at
javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:245)
	at
java.awt.Component.processMouseEvent(Component.java:5100)
	at
java.awt.Component.processEvent(Component.java:4897)
	at
java.awt.Container.processEvent(Container.java:1569)
	at
java.awt.Component.dispatchEventImpl(Component.java:3615)
	at
java.awt.Container.dispatchEventImpl(Container.java:1627)
	at
java.awt.Component.dispatchEvent(Component.java:3477)
	at
java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:3483)
	at
java.awt.LightweightDispatcher.processMouseEvent(Container.java:3198)
	at
java.awt.LightweightDispatcher.dispatchEvent(Container.java:3128)
	at
java.awt.Container.dispatchEventImpl(Container.java:1613)
	at
java.awt.Window.dispatchEventImpl(Window.java:1606)
	at
java.awt.Component.dispatchEvent(Component.java:3477)
[catch] at
java.awt.EventQueue.dispatchEvent(EventQueue.java:456)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:141)
	at java.awt.Dialog$1.run(Dialog.java:540)
	at java.awt.Dialog.show(Dialog.java:561)
	at
org.netbeans.core.windows.services.NbPresenter.superShow(NbPresenter.java:780)
	at
org.netbeans.core.windows.services.NbPresenter.doShow(NbPresenter.java:823)
	at
org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:811)
	at org.openide.util.Mutex$1.run(Mutex.java:937)
	at
java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:171)
	at
java.awt.EventQueue.dispatchEvent(EventQueue.java:454)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
	at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
	at
java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
Comment 1 bknights 2004-11-17 14:39:03 UTC
Created attachment 18933 [details]
NetBeans log file
Comment 2 bknights 2004-11-17 15:00:46 UTC
This is with 4.0 Beta 2.

Jdk is 
java version "1.4.2_04"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_04-b05)
Java HotSpot(TM) Client VM (build 1.4.2_04-b05, mixed mode)

Comment 3 bknights 2004-11-17 15:04:33 UTC
After re-opening NetBeans I tried creating a new web project from
exisiting sources. After selecting the source directory I got another
error: 

java.lang.reflect.UndeclaredThrowableException
	at $Proxy12.actionPerformed(Unknown Source)
	at
javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1786)
	at
javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(AbstractButton.java:1839)
	at
javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
	at
javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:245)
	at java.awt.Component.processMouseEvent(Component.java:5100)
	at java.awt.Component.processEvent(Component.java:4897)
	at java.awt.Container.processEvent(Container.java:1569)
	at java.awt.Component.dispatchEventImpl(Component.java:3615)
	at java.awt.Container.dispatchEventImpl(Container.java:1627)
	at java.awt.Component.dispatchEvent(Component.java:3477)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:3483)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3198)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3128)
	at java.awt.Container.dispatchEventImpl(Container.java:1613)
	at java.awt.Window.dispatchEventImpl(Window.java:1606)
	at java.awt.Component.dispatchEvent(Component.java:3477)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:456)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:141)
	at java.awt.Dialog$1.run(Dialog.java:540)
	at java.awt.Dialog.show(Dialog.java:561)
	at
org.netbeans.core.windows.services.NbPresenter.superShow(NbPresenter.java:780)
	at
org.netbeans.core.windows.services.NbPresenter.doShow(NbPresenter.java:823)
	at
org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:811)
	at org.openide.util.Mutex$1.run(Mutex.java:937)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:171)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:454)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:324)
	at
org.openide.util.WeakListenerImpl$ProxyListener.invoke(WeakListenerImpl.java:383)
	... 35 more
Caused by: java.lang.NullPointerException
	at
org.netbeans.modules.web.project.ui.wizards.ImportWebProjectWizardIterator.guessDocBase(ImportWebProjectWizardIterator.java:253)
	at
org.netbeans.modules.web.project.ui.wizards.ImportWebProjectWizardIterator.access$300(ImportWebProjectWizardIterator.java:63)
	at
org.netbeans.modules.web.project.ui.wizards.ImportWebProjectWizardIterator$SecondPanel.presetSecondPanel(ImportWebProjectWizardIterator.java:583)
	at
org.netbeans.modules.web.project.ui.wizards.ImportWebProjectWizardIterator$SecondPanel.readSettings(ImportWebProjectWizardIterator.java:548)
	at org.openide.WizardDescriptor.updateState(WizardDescriptor.java:520)
	at
org.openide.loaders.TemplateWizard.updateState(TemplateWizard.java:686)
	at
org.netbeans.modules.project.ui.NewProjectWizard.updateState(NewProjectWizard.java:39)
	at org.openide.WizardDescriptor.goToNextStep(WizardDescriptor.java:675)
	at org.openide.WizardDescriptor.access$500(WizardDescriptor.java:63)
	at
org.openide.WizardDescriptor$Listener.actionPerformed(WizardDescriptor.java:1275)
[catch] ... 40 more
==>
java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:324)
	at
org.openide.util.WeakListenerImpl$ProxyListener.invoke(WeakListenerImpl.java:383)
	at $Proxy12.actionPerformed(Unknown Source)
	at
javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1786)
	at
javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(AbstractButton.java:1839)
	at
javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
	at
javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:245)
	at java.awt.Component.processMouseEvent(Component.java:5100)
	at java.awt.Component.processEvent(Component.java:4897)
	at java.awt.Container.processEvent(Container.java:1569)
	at java.awt.Component.dispatchEventImpl(Component.java:3615)
	at java.awt.Container.dispatchEventImpl(Container.java:1627)
	at java.awt.Component.dispatchEvent(Component.java:3477)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:3483)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3198)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3128)
	at java.awt.Container.dispatchEventImpl(Container.java:1613)
	at java.awt.Window.dispatchEventImpl(Window.java:1606)
	at java.awt.Component.dispatchEvent(Component.java:3477)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:456)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:141)
	at java.awt.Dialog$1.run(Dialog.java:540)
	at java.awt.Dialog.show(Dialog.java:561)
	at
org.netbeans.core.windows.services.NbPresenter.superShow(NbPresenter.java:780)
	at
org.netbeans.core.windows.services.NbPresenter.doShow(NbPresenter.java:823)
	at
org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:811)
	at org.openide.util.Mutex$1.run(Mutex.java:937)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:171)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:454)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
Caused by: java.lang.NullPointerException
	at
org.netbeans.modules.web.project.ui.wizards.ImportWebProjectWizardIterator.guessDocBase(ImportWebProjectWizardIterator.java:253)
	at
org.netbeans.modules.web.project.ui.wizards.ImportWebProjectWizardIterator.access$300(ImportWebProjectWizardIterator.java:63)
	at
org.netbeans.modules.web.project.ui.wizards.ImportWebProjectWizardIterator$SecondPanel.presetSecondPanel(ImportWebProjectWizardIterator.java:583)
	at
org.netbeans.modules.web.project.ui.wizards.ImportWebProjectWizardIterator$SecondPanel.readSettings(ImportWebProjectWizardIterator.java:548)
	at org.openide.WizardDescriptor.updateState(WizardDescriptor.java:520)
	at
org.openide.loaders.TemplateWizard.updateState(TemplateWizard.java:686)
	at
org.netbeans.modules.project.ui.NewProjectWizard.updateState(NewProjectWizard.java:39)
	at org.openide.WizardDescriptor.goToNextStep(WizardDescriptor.java:675)
	at org.openide.WizardDescriptor.access$500(WizardDescriptor.java:63)
	at
org.openide.WizardDescriptor$Listener.actionPerformed(WizardDescriptor.java:1275)
[catch] ... 40 more
==>
java.lang.NullPointerException
	at
org.netbeans.modules.web.project.ui.wizards.ImportWebProjectWizardIterator.guessDocBase(ImportWebProjectWizardIterator.java:253)
	at
org.netbeans.modules.web.project.ui.wizards.ImportWebProjectWizardIterator.access$300(ImportWebProjectWizardIterator.java:63)
	at
org.netbeans.modules.web.project.ui.wizards.ImportWebProjectWizardIterator$SecondPanel.presetSecondPanel(ImportWebProjectWizardIterator.java:583)
	at
org.netbeans.modules.web.project.ui.wizards.ImportWebProjectWizardIterator$SecondPanel.readSettings(ImportWebProjectWizardIterator.java:548)
	at org.openide.WizardDescriptor.updateState(WizardDescriptor.java:520)
	at
org.openide.loaders.TemplateWizard.updateState(TemplateWizard.java:686)
	at
org.netbeans.modules.project.ui.NewProjectWizard.updateState(NewProjectWizard.java:39)
	at org.openide.WizardDescriptor.goToNextStep(WizardDescriptor.java:675)
	at org.openide.WizardDescriptor.access$500(WizardDescriptor.java:63)
	at
org.openide.WizardDescriptor$Listener.actionPerformed(WizardDescriptor.java:1275)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:324)
	at
org.openide.util.WeakListenerImpl$ProxyListener.invoke(WeakListenerImpl.java:383)
	at $Proxy12.actionPerformed(Unknown Source)
	at
javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1786)
	at
javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(AbstractButton.java:1839)
	at
javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
	at
javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:245)
	at java.awt.Component.processMouseEvent(Component.java:5100)
	at java.awt.Component.processEvent(Component.java:4897)
	at java.awt.Container.processEvent(Container.java:1569)
	at java.awt.Component.dispatchEventImpl(Component.java:3615)
	at java.awt.Container.dispatchEventImpl(Container.java:1627)
	at java.awt.Component.dispatchEvent(Component.java:3477)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:3483)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3198)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3128)
	at java.awt.Container.dispatchEventImpl(Container.java:1613)
	at java.awt.Window.dispatchEventImpl(Window.java:1606)
	at java.awt.Component.dispatchEvent(Component.java:3477)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:456)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:141)
	at java.awt.Dialog$1.run(Dialog.java:540)
	at java.awt.Dialog.show(Dialog.java:561)
	at
org.netbeans.core.windows.services.NbPresenter.superShow(NbPresenter.java:780)
	at
org.netbeans.core.windows.services.NbPresenter.doShow(NbPresenter.java:823)
	at
org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:811)
	at org.openide.util.Mutex$1.run(Mutex.java:937)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:171)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:454)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
Comment 4 bknights 2004-11-17 15:15:02 UTC
Second trace occurs after the dialog that tells me NB has found an
existing build.xml in specified project directory and that it is going
to create nbbuild.xml there as well. The error doesn't occur if I
specify a directory that doesn't contain a build.xml file.

Comment 5 David Konecny 2004-11-18 09:17:19 UTC
Beta2 issue. This might be fixed already in newer builds.
Comment 6 bknights 2004-11-18 16:14:50 UTC
I have downloaded the latest build I could find and the problem
persists. From the Help |About menu my NB build is 200409220845.
Is there a later one available?
Comment 7 bknights 2004-11-18 17:13:19 UTC
I can confirm this is fixed in the build dated: 200411072021
Comment 8 David Konecny 2004-11-19 10:24:21 UTC
Thanks!
Comment 9 Marian Mirilovic 2005-07-12 10:08:07 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo