Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 50684 - [Freeform] Enable project actions even if there isn't a corresponding build target
[Freeform] Enable project actions even if there isn't a corresponding build t...
Status: CLOSED DUPLICATE of bug 46886
Product: projects
Classification: Unclassified
Component: Ant
4.x
All All
: P3 (vote)
: 4.x
Assigned To: Jesse Glick
issues@projects
buildsys-e-cand
:
Depends on:
Blocks: 42682
  Show dependency treegraph
 
Reported: 2004-10-21 08:29 UTC by jrojcek
Modified: 2006-03-24 10:15 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jrojcek 2004-10-21 08:29:00 UTC
Standard project actions like:
Build, Run, Test, Debug, Fix and Continue

and also file actions like:
Compile File, Run File, Test File, Debug Test File

should be enabled even if the user doesn't supply an Ant build 
target that should perform that action. If the user invokes such 
action, it should show a dialog asking the user supply a build 
target with a pointer to the help system explaining how to write 
such build target.
Comment 1 Jesse Glick 2004-10-21 16:32:35 UTC
Note: Fix & Continue is a file action, not a project action.

Could perhaps be tied together with the fix for issue #46886? E.g. if
you have no binding for "Debug", trying to debug would pop up a dialog
with not just a link to help, but also a sample target in a r/o
textarea with a Copy button.
Comment 2 Jesse Glick 2004-12-02 21:03:03 UTC

*** This issue has been marked as a duplicate of 46886 ***
Comment 3 Marian Mirilovic 2005-12-20 16:05:16 UTC
This issue was solved long time ago. Because nobody has reopened it neither
added comments, we are verifying/closing it now. 
If you are still able to reproduce the problem, please reopen. 

Thanks in advance.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo