Bug 50423 - [40cat] Can't type in dialog "New Property"
[40cat] Can't type in dialog "New Property"
Status: CLOSED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
4.x
All Linux
: P2 (vote)
: 4.x
Assigned To: Jaroslav Tulach
issues@platform
http://bugs.sun.com/bugdatabase/view_...
jdk_bug_6183877
: A11Y, FOCUS
: 52674 64922 65066 67366 69179 71678 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-14 12:58 UTC by pfelenda
Modified: 2008-12-22 17:54 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Taken after the dialog got the focus - this shows that the array of the typeAheadMarkers is not cleared even it should be (32.35 KB, image/jpeg)
2004-10-24 19:53 UTC, Jaroslav Tulach
Details
A bit of reflection to detect the typeahead starvation and flush content of the key buffer (4.05 KB, patch)
2005-11-25 08:44 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description pfelenda 2004-10-14 12:58:56 UTC
Build 200410131800, jdk1.5.0

Steps to reproduce:
 - Open properties file in table view 
 - Open dialog "New Property" from keyboard (Alt-N)
-> Cursor is blinking in dialog, but no character
are displayed while typing.
Comment 1 pfelenda 2004-10-14 13:06:38 UTC
I am able to reproduce it only on Linux Fedora Core 2.
Comment 2 zikmund 2004-10-14 14:01:12 UTC
Discovered by NetCAT program participant - adding [40cat] prefix.
Comment 3 Jan Stola 2004-10-14 15:09:39 UTC
Doesn't seem to be specific for this dialog. I was able to reproduce
the same behaviour (on pfelenda's machine) also with the following
dialogs: New Watch, New Breakpoint and Edit URL.
They are created using DialogDisplayer => reassigning to openide
for evaluation.
Comment 4 _ ttran 2004-10-15 14:30:13 UTC
please evaluate it yourself.  Until you have reasons to believe this
is a bug in openide, don't assign it to openide.  Core is not a
dumping ground.

Thank you
Comment 5 Marian Petras 2004-10-20 11:25:35 UTC
I saw the same problem also with other dialogs (e.g. the New File
wizard). In most cases, it was reproduced on a remotely connected
Linux desktop, but it was reproduced also on a local desktop.

The symptoms are exactly the same as the symptoms of JDK bug #5097241
- "None of the comps in FileDlg receive keyevents on Solaris9 (CDE)
with XToolkit" (see
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=5097241).

Also the synopsis mentions only Solaris, the reporter states in the
bug's description, that "This is reproducible when logging into a
remote linux machine through ...".
Comment 6 Marian Petras 2004-10-20 11:27:21 UTC
Correction:
The third paragraph should start with "Although ...", not "Also ..."
Comment 7 Marian Petras 2004-10-20 16:07:38 UTC
The same problem has been reproduced also in the following dialogs:

   New File (wizard)
   New Breakpoint (debugger)
   Rename Package (refactoring)

As for the Rename Package dialog, it is special in that the dialog was
invoked by a mouse.
Comment 8 Jan Chalupa 2004-10-20 16:51:41 UTC
Reproduced with various dialogs on Linux with JDK 5.0. It may be a JDK
bug, but we need to do more investigation to be done on our side.

Re-assigning to core. Yarda, I know you've done some debugging on
this. Please add your comments here. Thanks.
Comment 9 Jan Chalupa 2004-10-20 16:52:15 UTC
Changing subcomponent.
Comment 10 Jaroslav Tulach 2004-10-24 19:38:36 UTC
Amusement story at the begining: I managed to simulate the problem under 
debugger, but it was imposible to debug, as when I switched to another instance of 
NetBeans and back the problem got fixed. That means, we have a workaround - if 
you get into this situation, just switch to another application and back and the 
dialog becomes "typable". 
 
Comment 11 Jaroslav Tulach 2004-10-24 19:51:55 UTC
I succeed with debugging then - I started another X server and run each  program 
in own display. The problem is caused by code that is desiigned to delay 
keystrokes until a component is focused probably to prevent keystrokes to be 
delivered to wrong window (as far as I know it is new to 1.5). Sometimes the code 
gets confused, probably by the dialog not receiving focus. 
 
I'll add two pictures showing that the array of typeAheadMarkers is not empty. 
Imho this is bug in JDK, I can fire one for them. But please, focus experts speak 
up if you think that this can be  something we are causing. 
Comment 12 Jaroslav Tulach 2004-10-24 19:53:35 UTC
Created attachment 18475 [details]
Taken after the dialog got the focus - this shows that the array of the typeAheadMarkers is not cleared even it should be
Comment 13 Jaroslav Tulach 2004-10-24 20:23:48 UTC
I assigned this bug to david to tell us more about the focus.
Personally I suggest to close it as wontfix and add one bug to jdk
team describing what happens. Plus maybe add this as release note, the
you may need to switch to anothe app and back to fix the problem.
Comment 14 vanob 2004-10-25 08:00:13 UTC
More info for consideration:

The bug was reporduced by me on Fedora Core 2, WindowMaker standalone.
I use jdk 1.5 to run netbeans and encountered a really annoying bug
in jdk 1.5 that is about jdk 1.5 apps stealing focus.

Here is the reference. Maybe this is the bug that preventing NetBeans
to function correctly. I would be happy if it's the case, otherwise I'm
afraid that the bug filed against jdk will be fixed after 2 yaers or so.

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=5094112
Comment 15 David Simonek 2004-10-25 16:49:21 UTC
From focus point of view, I'd say Netbeans does nothing bad or
dangerous in focus area that may result in bug we're talking about. I
checked again and no extra focus calls when opening Dialogs AFAIK. I
also recommend to close as wontfix and file a bug against JDK team, I
think Yarda's investigation is deep enough.
Comment 16 Jaroslav Tulach 2004-10-25 17:14:43 UTC
Seems like problem in JDK.
Comment 17 vanob 2004-10-26 07:03:28 UTC
jdk bug 6183877 does not seem to exist.
Are you sure it's a correct number?
Comment 18 Jan Chalupa 2004-10-26 08:26:27 UTC
The bug does exist. I've just checked it. I think it takes a couple
days to propagate it from the Sun internal bug tracking system to the
JDC Bug Parade. Please try again later.
Comment 19 mslama 2004-11-11 13:44:37 UTC
I am able to reproduce similar (or the same not sure how to verify)
problem with focus: When I open Find dialog from Projects tab on some
package node it looks like focus is in Substring edit box but I cannot
paste or write any character to it. When I click to Regular Expression
edit box writtens/pasted chars appear here and then I can click and
write into Substring edit box. Also when I close Find dialog focus
does not return to Main window. It is annoying bug but simple
wrokaround exists as described. I just tested JDK 1.5.0_02-ea-b02 and
it does not happen. (It also does not happen in JDK 1.6.0 build 11.)

Yes I admit I do not have typical configuration: I have exported X Win
from my notebook with FC2 to desktop with RH 8 + Gnome. I run Gnome.
Comment 20 mslama 2004-11-11 14:20:54 UTC
I am not able to reproduce it anymore even with JDK 1.5.0. Weird. So
my previous post is irrelevant.
Comment 21 _ lcincura 2005-01-10 11:44:06 UTC
*** Issue 52674 has been marked as a duplicate of this issue. ***
Comment 22 Marian Mirilovic 2005-07-14 08:42:00 UTC
closing
Comment 23 Jan Chalupa 2005-09-25 08:05:15 UTC
*** Issue 65066 has been marked as a duplicate of this issue. ***
Comment 24 Marian Petras 2005-10-21 14:21:31 UTC
*** Issue 64922 has been marked as a duplicate of this issue. ***
Comment 25 Jaroslav Tulach 2005-10-24 14:34:15 UTC
*** Issue 67366 has been marked as a duplicate of this issue. ***
Comment 26 Jaroslav Tulach 2005-11-25 07:45:38 UTC
*** Issue 69179 has been marked as a duplicate of this issue. ***
Comment 27 Jaroslav Tulach 2005-11-25 08:42:42 UTC
Happens to me all the time, when opening cvs commit window as well as new 
watch dialog. 
Comment 28 Jaroslav Tulach 2005-11-25 08:44:48 UTC
Created attachment 27268 [details]
A bit of reflection to detect the typeahead starvation and flush content of the key buffer
Comment 29 Jaroslav Tulach 2005-11-25 09:16:53 UTC
#50423: Use -Dnetbeans.hack.50423=true to enable reflection based workaround 
for the type ahead problem 
 
new revision: 1.8; previous revision: 1.7 
done 
Checking in windows/src/org/netbeans/core/windows/services/NbPresenter.java; 
/cvs/core/windows/src/org/netbeans/core/windows/services/NbPresenter.java,v  
<--  NbPresenter.java 
new revision: 1.26; previous revision: 1.25 
Comment 30 Marian Mirilovic 2005-12-22 14:35:37 UTC
The JDK issue has been already fixed for upcoming JDK 6.0, closing
Comment 31 Marek Grummich 2006-01-23 12:39:01 UTC
*** Issue 71678 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo