Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 50363 - Merge editor status bar into global status line
Merge editor status bar into global status line
Status: RESOLVED DUPLICATE of bug 123344
Product: platform
Classification: Unclassified
Component: Window System
4.x
PC All
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
: UI
Depends on:
Blocks: 50356
  Show dependency treegraph
 
Reported: 2004-10-13 16:28 UTC by David Simonek
Modified: 2008-12-22 10:40 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Simonek 2004-10-13 16:28:08 UTC
Editor status line should be moved and merged with
global status line.

Pending:
- how to get informations from editor module to
show them in main status line
- SDI problems: status line in main window doesn't
make much sense, especially when part of status
line will be editor's related.
- multi-monitor problems: when having multiple
separated editor areas, how should status line behave?
Comment 1 David Simonek 2005-05-09 12:32:49 UTC
Valid, but postponed.
Comment 2 Milos Kleint 2005-05-10 08:29:38 UTC
there's api for placing custom items into statusl line
org.openide.awt.StatusLineElementProvider
Comment 3 Ondrej Langr 2008-10-27 16:16:15 UTC
Still valid, but has been filed as #123344 together with link to UI specification and more detailed explanation. I'm
closing this task to clean up.

*** This issue has been marked as a duplicate of 123344 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo