Bug 50238 - Error when running a web application
Error when running a web application
Status: RESOLVED DUPLICATE of bug 48590
Product: web
Classification: Unclassified
Component: HTML Editor
4.x
PC Windows XP
: P1 (vote)
: 4.x
Assigned To: issues@web
issues@web
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-11 17:23 UTC by mikeborozdin
Modified: 2004-10-11 17:30 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikeborozdin 2004-10-11 17:23:01 UTC
I get an error when running a web application.

Here is an error log:

*********** Exception occurred ************ at 
8:13 PM on Oct 11, 2004
java.lang.NullPointerException
	at org.openide.awt.HtmlBrowser.<init>
(HtmlBrowser.java:205)
	at 
org.netbeans.core.HtmlBrowserComponent.<init>
(HtmlBrowserComponent.java:83)
	at 
org.netbeans.core.NbTopManager$NbBrowser.<init>
(NbTopManager.java:613)
	at org.netbeans.core.NbTopManager$1.run
(NbTopManager.java:328)
	at 
java.awt.event.InvocationEvent.dispatch
(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent
(EventQueue.java:461)
[catch] at 
java.awt.EventDispatchThread.pumpOneEventForHiera
rchy(EventDispatchThread.java:234)
	at 
java.awt.EventDispatchThread.pumpEventsForHierarc
hy(EventDispatchThread.java:163)
	at 
java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:157)
	at 
java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run
(EventDispatchThread.java:110)
*********** Exception occurred ************ at 
8:14 PM on Oct 11, 2004
java.lang.IllegalStateException: Duplicate pair 
in treePair1: SL[/Browsers/NetscapeBrowser 
pair2: SL[/Browsers/NetscapeBrowser index1: 4 
index2: 4 item1: 
org.netbeans.modules.extbrowser.NetscapeBrowser@1
ab6087 item2: 
org.netbeans.modules.extbrowser.NetscapeBrowser@1
ab6087 id1: 387bc2 id2: 4507ed
	at 
org.openide.util.lookup.ALPairComparator.compare
(ALPairComparator.java:52)
	at java.util.TreeMap.compare
(TreeMap.java:1093)
	at java.util.TreeMap.put
(TreeMap.java:465)
	at java.util.TreeSet.add
(TreeSet.java:210)
	at 
org.openide.util.lookup.AbstractLookup$R.initItem
s(AbstractLookup.java:788)
	at 
org.openide.util.lookup.AbstractLookup$R.allItems
WithoutBeforeLookup(AbstractLookup.java:749)
	at 
org.openide.util.lookup.AbstractLookup$R.allInsta
nces(AbstractLookup.java:691)
	at 
org.openide.util.lookup.ProxyLookup$R.computeResu
lt(ProxyLookup.java:378)
	at 
org.openide.util.lookup.ProxyLookup$R.allInstance
s(ProxyLookup.java:329)
	at 
org.openide.util.lookup.ProxyLookup$R.computeResu
lt(ProxyLookup.java:378)
	at 
org.openide.util.lookup.ProxyLookup$R.allInstance
s(ProxyLookup.java:329)
[catch] at 
org.netbeans.core.IDESettings.getWWWBrowser
(IDESettings.java:345)
	at 
org.netbeans.core.NbTopManager$NbBrowser.<init>
(NbTopManager.java:613)
	at org.netbeans.core.NbTopManager$1.run
(NbTopManager.java:328)
	at 
java.awt.event.InvocationEvent.dispatch
(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent
(EventQueue.java:461)
	at 
java.awt.EventDispatchThread.pumpOneEventForHiera
rchy(EventDispatchThread.java:234)
	at 
java.awt.EventDispatchThread.pumpEventsForHierarc
hy(EventDispatchThread.java:163)
	at 
java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:157)
	at 
java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run
(EventDispatchThread.java:110)
*********** Exception occurred ************ at 
8:14 PM on Oct 11, 2004
Annotation: Exception during initialization of 
HTML browser module
java.lang.IllegalStateException: Duplicate pair 
in treePair1: SL[/Browsers/NetscapeBrowser 
pair2: SL[/Browsers/NetscapeBrowser index1: 4 
index2: 4 item1: 
org.netbeans.modules.extbrowser.NetscapeBrowser@1
ab6087 item2: 
org.netbeans.modules.extbrowser.NetscapeBrowser@1
ab6087 id1: 387bc2 id2: 4507ed
	at 
org.openide.util.lookup.ALPairComparator.compare
(ALPairComparator.java:52)
	at java.util.TreeMap.compare
(TreeMap.java:1093)
	at java.util.TreeMap.put
(TreeMap.java:465)
	at java.util.TreeSet.add
(TreeSet.java:210)
	at 
org.openide.util.lookup.AbstractLookup$R.initItem
s(AbstractLookup.java:788)
	at 
org.openide.util.lookup.AbstractLookup$R.allItems
WithoutBeforeLookup(AbstractLookup.java:749)
	at 
org.openide.util.lookup.AbstractLookup$R.allInsta
nces(AbstractLookup.java:691)
	at 
org.openide.util.lookup.ProxyLookup$R.computeResu
lt(ProxyLookup.java:378)
	at 
org.openide.util.lookup.ProxyLookup$R.allInstance
s(ProxyLookup.java:329)
	at 
org.openide.util.lookup.ProxyLookup$R.computeResu
lt(ProxyLookup.java:378)
	at 
org.openide.util.lookup.ProxyLookup$R.allInstance
s(ProxyLookup.java:329)
	at 
org.openide.awt.HtmlBrowser.findComponent
(HtmlBrowser.java:226)
[catch] at org.openide.awt.HtmlBrowser.<init>
(HtmlBrowser.java:173)
	at 
org.netbeans.core.HtmlBrowserComponent.<init>
(HtmlBrowserComponent.java:83)
	at 
org.netbeans.core.NbTopManager$NbBrowser.<init>
(NbTopManager.java:613)
	at org.netbeans.core.NbTopManager$1.run
(NbTopManager.java:328)
	at 
java.awt.event.InvocationEvent.dispatch
(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent
(EventQueue.java:461)
	at 
java.awt.EventDispatchThread.pumpOneEventForHiera
rchy(EventDispatchThread.java:234)
	at 
java.awt.EventDispatchThread.pumpEventsForHierarc
hy(EventDispatchThread.java:163)
	at 
java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:157)
	at 
java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run
(EventDispatchThread.java:110)
*********** Exception occurred ************ at 
8:14 PM on Oct 11, 2004
java.lang.NullPointerException
	at org.openide.awt.HtmlBrowser.<init>
(HtmlBrowser.java:205)
	at 
org.netbeans.core.HtmlBrowserComponent.<init>
(HtmlBrowserComponent.java:83)
	at 
org.netbeans.core.NbTopManager$NbBrowser.<init>
(NbTopManager.java:613)
	at org.netbeans.core.NbTopManager$1.run
(NbTopManager.java:328)
	at 
java.awt.event.InvocationEvent.dispatch
(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent
(EventQueue.java:461)
[catch] at 
java.awt.EventDispatchThread.pumpOneEventForHiera
rchy(EventDispatchThread.java:234)
	at 
java.awt.EventDispatchThread.pumpEventsForHierarc
hy(EventDispatchThread.java:163)
	at 
java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:157)
	at 
java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run
(EventDispatchThread.java:110)
Comment 1 Martin Grebac 2004-10-11 17:30:31 UTC

*** This issue has been marked as a duplicate of 48590 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo