Bug 50129 - Drag-and-drop of file Java file onto IDE background should open it in editor
Drag-and-drop of file Java file onto IDE background should open it in editor
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
4.x
All All
: P1 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
: UI
: 41262 69089 (view as bug list)
Depends on: 77154
Blocks: 70468
  Show dependency treegraph
 
Reported: 2004-10-07 20:52 UTC by jessholle
Modified: 2008-12-23 14:33 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jessholle 2004-10-07 20:52:50 UTC
Currently most everyone who uses NetBeans that I
know must keep another quasi-Java-savvy editor
laying around to drop files onto for quick viewing.

For instance, you get a Java source file via
e-mail and want to quickly view it (with syntax
highlighting method/field drop down, etc).

You should be able to double-click on the file or
drag it and drop it onto the IDE's internal
desktop or the IDE's icon to open it into the IDE.
 This should work irregardless of whether the file
in question resides within an open project's
source directories.  If it does, then it should
certainly be treated just as if it was opened from
within the IDE "normally".

This is a major usability gap in NetBeans.  One
should not have to juggle a separate editor for
this purpose when one already has NetBeans running.
Comment 1 jessholle 2005-04-03 15:38:27 UTC
This is still a fairly obnoxious thing about NetBeans.  I have to keep another
Java-aware editor available and use it frequently for quickly looking at Java
source, properties, and XML files from the desktop from outside the project
source tree.

NetBeans should just allow me to look at such files -- irrespective of whether
they're in a project directory or not.  Not allowing use of its capable editor
on arbitrary files via normal drag-and-drop and double-click mechanisms requires
users working on files not currently in NetBeans projects to use a second editor
and thus reduces both NetBeans' utility and mindshare with the given user.
Comment 2 Miloslav Metelka 2005-04-05 10:50:45 UTC
Should IMHO be resolved globally by our D&D support. Reassigning to core/winsys
for evaluation.
Comment 3 David Simonek 2005-05-09 12:26:03 UTC
"globally by our D&D support"? We don't have any global DnD for data, we have
only DnD of windows in window system. I think cooperation of java/editor is
needed, at least. Actulally I don't know whether/how is would be doable.
Comment 4 Milos Kleint 2005-07-21 09:24:03 UTC
What exactly should be the active area for placing the files in the IDE? the
editor? the editor tabs?

I suppose editor needs to implement a reasonable TransferHandler that will cover
this usecase, like when the dragged transferable is a file, copy it's content
into the editor window?

we don't have a global d&d support + there is one for windowsystem and one for
explorer views, these should be at least partly abandoned in favour of jdk
1.4.2's support.

Comment 5 jessholle 2005-07-24 23:23:20 UTC
You should be able to drop on the background when nothing is open for starters.

Dropping into the tab area makes sense too -- as does dropping on an editor
window, though I'd think this ought to delegate back to the tabs...
Comment 6 Miloslav Metelka 2005-11-22 11:58:47 UTC
*** Issue 69089 has been marked as a duplicate of this issue. ***
Comment 7 Stanislav Aubrecht 2006-05-23 15:15:25 UTC
*** Issue 41262 has been marked as a duplicate of this issue. ***
Comment 8 Stanislav Aubrecht 2006-06-08 11:18:35 UTC
fixed

Checking in utilities/test/cfg-unit.xml;
/cvs/utilities/test/cfg-unit.xml,v  <--  cfg-unit.xml
new revision: 1.2; previous revision: 1.1
done
Checking in utilities/test/build-unit.xml;
/cvs/utilities/test/build-unit.xml,v  <--  build-unit.xml
new revision: 1.2; previous revision: 1.1
done
Checking in utilities/test/build.xml;
/cvs/utilities/test/build.xml,v  <--  build.xml
new revision: 1.2; previous revision: 1.1
done
Checking in openide/explorer/src/org/openide/explorer/view/ListView.java;
/cvs/openide/explorer/src/org/openide/explorer/view/ListView.java,v  <-- 
ListView.java
new revision: 1.9; previous revision: 1.8
done
Checking in openide/explorer/src/org/openide/explorer/view/TreeViewDropSupport.java;
/cvs/openide/explorer/src/org/openide/explorer/view/TreeViewDropSupport.java,v 
<--  TreeViewDropSupport.java
new revision: 1.5; previous revision: 1.4
done
Checking in openide/explorer/src/org/openide/explorer/view/ListViewDropSupport.java;
/cvs/openide/explorer/src/org/openide/explorer/view/ListViewDropSupport.java,v 
<--  ListViewDropSupport.java
new revision: 1.5; previous revision: 1.4
done
Checking in openide/explorer/src/org/openide/explorer/view/TreeView.java;
/cvs/openide/explorer/src/org/openide/explorer/view/TreeView.java,v  <-- 
TreeView.java
new revision: 1.11; previous revision: 1.10
done
Checking in openide/explorer/src/org/openide/explorer/view/ExplorerDnDManager.java;
/cvs/openide/explorer/src/org/openide/explorer/view/ExplorerDnDManager.java,v 
<--  ExplorerDnDManager.java
new revision: 1.2; previous revision: 1.1
done
Checking in utilities/src/META-INF/services/org.openide.windows.ExternalDropHandler;
/cvs/utilities/src/META-INF/services/org.openide.windows.ExternalDropHandler,v 
<--  org.openide.windows.ExternalDropHandler
new revision: 1.2; previous revision: 1.1
done
Checking in openide/loaders/api/apichanges.xml;
/cvs/openide/loaders/api/apichanges.xml,v  <--  apichanges.xml
new revision: 1.20; previous revision: 1.19
done
Checking in openide/text/apichanges.xml;
/cvs/openide/text/apichanges.xml,v  <--  apichanges.xml
new revision: 1.12; previous revision: 1.11
done
Checking in openide/text/manifest.mf;
/cvs/openide/text/manifest.mf,v  <--  manifest.mf
new revision: 1.13; previous revision: 1.12
done
Checking in openide/loaders/nbproject/project.xml;
/cvs/openide/loaders/nbproject/project.xml,v  <--  project.xml
new revision: 1.14; previous revision: 1.13
done
Checking in openide/loaders/nbproject/project.properties;
/cvs/openide/loaders/nbproject/project.properties,v  <--  project.properties
new revision: 1.11; previous revision: 1.10
done
Checking in core/windows/src/org/netbeans/core/windows/view/EditorView.java;
/cvs/core/windows/src/org/netbeans/core/windows/view/EditorView.java,v  <-- 
EditorView.java
new revision: 1.20; previous revision: 1.19
done
Checking in
utilities/src/org/netbeans/modules/openfile/DefaultExternalDropHandler.java;
/cvs/utilities/src/org/netbeans/modules/openfile/DefaultExternalDropHandler.java,v
 <--  DefaultExternalDropHandler.java
new revision: 1.2; previous revision: 1.1
done
Checking in utilities/src/org/netbeans/modules/openfile/OpenFile.java;
/cvs/utilities/src/org/netbeans/modules/openfile/OpenFile.java,v  <--  OpenFile.java
new revision: 1.62; previous revision: 1.61
done
Checking in openide/windows/src/org/openide/windows/ExternalDropHandler.java;
/cvs/openide/windows/src/org/openide/windows/ExternalDropHandler.java,v  <-- 
ExternalDropHandler.java
new revision: 1.2; previous revision: 1.1
done
Checking in openide/text/src/org/openide/text/QuietEditorPane.java;
/cvs/openide/text/src/org/openide/text/QuietEditorPane.java,v  <-- 
QuietEditorPane.java
new revision: 1.6; previous revision: 1.5
done
Checking in core/windows/nbproject/project.xml;
/cvs/core/windows/nbproject/project.xml,v  <--  project.xml
new revision: 1.13; previous revision: 1.12
done
Checking in openide/loaders/src/org/openide/loaders/DataNode.java;
/cvs/openide/loaders/src/org/openide/loaders/DataNode.java,v  <--  DataNode.java
new revision: 1.25; previous revision: 1.24
done
Checking in openide/loaders/src/org/openide/loaders/DataFolder.java;
/cvs/openide/loaders/src/org/openide/loaders/DataFolder.java,v  <--  DataFolder.java
new revision: 1.47; previous revision: 1.46
done
Checking in openide/loaders/manifest.mf;
/cvs/openide/loaders/manifest.mf,v  <--  manifest.mf
new revision: 1.28; previous revision: 1.27
done
Checking in openide/explorer/manifest.mf;
/cvs/openide/explorer/manifest.mf,v  <--  manifest.mf
new revision: 1.9; previous revision: 1.8
done
Checking in openide/explorer/apichanges.xml;
/cvs/openide/explorer/apichanges.xml,v  <--  apichanges.xml
new revision: 1.7; previous revision: 1.6
done
Checking in openide/windows/manifest.mf;
/cvs/openide/windows/manifest.mf,v  <--  manifest.mf
new revision: 1.8; previous revision: 1.7
done
Checking in openide/windows/apichanges.xml;
/cvs/openide/windows/apichanges.xml,v  <--  apichanges.xml
new revision: 1.4; previous revision: 1.3
done
Checking in
utilities/test/unit/src/org/netbeans/modules/openfile/DefaultExternalDropHandlerTest.java;
/cvs/utilities/test/unit/src/org/netbeans/modules/openfile/DefaultExternalDropHandlerTest.java,v
 <--  DefaultExternalDropHandlerTest.java
new revision: 1.2; previous revision: 1.1
done
Checking in openide/text/nbproject/project.xml;
/cvs/openide/text/nbproject/project.xml,v  <--  project.xml
new revision: 1.8; previous revision: 1.7
done
Checking in
openide/loaders/test/unit/src/org/openide/loaders/DataFolderPasteTypesTest.java;
/cvs/openide/loaders/test/unit/src/org/openide/loaders/DataFolderPasteTypesTest.java,v
 <--  DataFolderPasteTypesTest.java
new revision: 1.2; previous revision: 1.1
done
Checking in
openide/loaders/test/unit/src/org/openide/loaders/DragAndDropDataNodeTest.java;
/cvs/openide/loaders/test/unit/src/org/openide/loaders/DragAndDropDataNodeTest.java,v
 <--  DragAndDropDataNodeTest.java
new revision: 1.2; previous revision: 1.1
done
Checking in utilities/nbproject/project.xml;
/cvs/utilities/nbproject/project.xml,v  <--  project.xml
new revision: 1.16; previous revision: 1.15
done
Checking in utilities/nbproject/project.properties;
/cvs/utilities/nbproject/project.properties,v  <--  project.properties
new revision: 1.15; previous revision: 1.14
done
Comment 9 Quality Engineering 2008-12-23 14:33:40 UTC
This issue had *1 votes* before move to platform component


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo